summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/capistrano/capistrano-1.4.1.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-1.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-1.4.1.ebuild b/dev-ruby/capistrano/capistrano-1.4.1.ebuild
new file mode 100644
index 000000000000..83d3fca1470e
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-1.4.1.ebuild,v 1.1 2007/02/27 20:31:50 graaff Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://rubyforge.org/projects/capistrano/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+#RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rake-0.7.0
+ >=dev-ruby/net-ssh-1.0.10
+ >=dev-ruby/net-sftp-1.1.0"
+
+pkg_postinst()
+{
+ elog
+ elog "Capistrano has replaced switchtower due to naming issues. If you were previously using"
+ elog "switchtower in your Rails apps, you need to manually remove lib/tasks/switchtower.rake"
+ elog "from them and then run 'cap -A .' in your project directory, making sure to keep deploy.rb"
+ elog
+}