summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/polyglot/polyglot-0.3.0.ebuild')
-rw-r--r--dev-ruby/polyglot/polyglot-0.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/polyglot/polyglot-0.3.0.ebuild b/dev-ruby/polyglot/polyglot-0.3.0.ebuild
new file mode 100644
index 000000000000..bfdf04fcee68
--- /dev/null
+++ b/dev-ruby/polyglot/polyglot-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/polyglot/polyglot-0.3.0.ebuild,v 1.1 2010/03/04 07:48:49 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Polyglot provides support for fully-custom DSLs."
+HOMEPAGE="http://polyglot.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+each_ruby_test() {
+ ${RUBY} test/test_polyglot.rb || die "tests failed"
+}