summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rake-compiler')
-rw-r--r--dev-ruby/rake-compiler/ChangeLog11
-rw-r--r--dev-ruby/rake-compiler/files/rake-compiler-0.7.0+ruby-1.8.7.patch24
-rw-r--r--dev-ruby/rake-compiler/rake-compiler-0.7.0-r1.ebuild59
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-ruby/rake-compiler/ChangeLog b/dev-ruby/rake-compiler/ChangeLog
index 25ec97bbb4a0..6d83b3154b4a 100644
--- a/dev-ruby/rake-compiler/ChangeLog
+++ b/dev-ruby/rake-compiler/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/rake-compiler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.6 2010/01/17 14:02:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/ChangeLog,v 1.7 2010/01/28 12:03:14 flameeyes Exp $
+
+*rake-compiler-0.7.0-r1 (28 Jan 2010)
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +rake-compiler-0.7.0-r1.ebuild,
+ +files/rake-compiler-0.7.0+ruby-1.8.7.patch:
+ Revision bump to enable all tests, and add proper dependencies. Tests are
+ disabled for ruby19 and jruby for now as they need full rubygems support.
+ Also add patch for tests to work fine with Ruby 1.8.7.
17 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
rake-compiler-0.7.0.ebuild:
diff --git a/dev-ruby/rake-compiler/files/rake-compiler-0.7.0+ruby-1.8.7.patch b/dev-ruby/rake-compiler/files/rake-compiler-0.7.0+ruby-1.8.7.patch
new file mode 100644
index 000000000000..5e1c43184827
--- /dev/null
+++ b/dev-ruby/rake-compiler/files/rake-compiler-0.7.0+ruby-1.8.7.patch
@@ -0,0 +1,24 @@
+From 7b7af198545cf831c6cde2c200bc248b1ee6e78c Mon Sep 17 00:00:00 2001
+From: Luis Parravicini <lparravi@gmail.com>
+Date: Sun, 27 Dec 2009 22:32:29 +0800
+Subject: [PATCH] bugfix for issue 15
+
+---
+ spec/lib/rake/extensiontask_spec.rb | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/spec/lib/rake/extensiontask_spec.rb b/spec/lib/rake/extensiontask_spec.rb
+index c13ec88..36152e2 100644
+--- a/spec/lib/rake/extensiontask_spec.rb
++++ b/spec/lib/rake/extensiontask_spec.rb
+@@ -439,6 +439,7 @@ describe Rake::ExtensionTask do
+ def mock_config_yml
+ {
+ 'rbconfig-1.8.6' => '/some/path/version/1.8/to/rbconfig.rb',
++ 'rbconfig-1.8.7' => '/some/path/version/1.8/to/rbconfig.rb',
+ 'rbconfig-1.9.1' => '/some/path/version/1.9.1/to/rbconfig.rb',
+ 'rbconfig-3.0.0' => '/some/fake/version/3.0.0/to/rbconfig.rb'
+ }
+--
+1.6.6.1
+
diff --git a/dev-ruby/rake-compiler/rake-compiler-0.7.0-r1.ebuild b/dev-ruby/rake-compiler/rake-compiler-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..b558a0b164e4
--- /dev/null
+++ b/dev-ruby/rake-compiler/rake-compiler-0.7.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rake-compiler/rake-compiler-0.7.0-r1.ebuild,v 1.1 2010/01/28 12:03:14 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+# Tests for now seem only to work when rubygems is fully installed for
+# the implementation and that for now only means Ruby 1.8
+RUBY_FAKEGEM_TASK_TEST="spec cucumber"
+
+RUBY_FAKEGEM_DOCDIR="doc/api"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Provide a standard and simplified way to build and package Ruby extensions"
+HOMEPAGE="http://github.com/luislavena/rake-compiler"
+LICENSE="as-is" # truly
+
+SRC_URI="http://github.com/luislavena/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+S="${WORKDIR}/luislavena-${PN}-2834041"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend doc ">=dev-ruby/rdoc-2.4.3"
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend "test ruby_targets_ruby18" "dev-ruby/rspec dev-util/cucumber dev-ruby/rubygems"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}+ruby-1.8.7.patch
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ # Remove this task so that it won't load on Ruby 1.9 and JRuby
+ # that lack the package_task file. It is, though, needed for the
+ # tests
+ rm tasks/gem.rake || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19|*jruby)
+ ewarn "Tests disabled for this implementation. Long story, check ebuild if you want."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}