summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rexml/rexml-3.0.2.ebuild')
-rw-r--r--dev-ruby/rexml/rexml-3.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rexml/rexml-3.0.2.ebuild b/dev-ruby/rexml/rexml-3.0.2.ebuild
new file mode 100644
index 000000000000..eb3f62010e16
--- /dev/null
+++ b/dev-ruby/rexml/rexml-3.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rexml/rexml-3.0.2.ebuild,v 1.1 2004/04/10 15:46:02 usata Exp $
+
+inherit ruby
+
+MY_P="${P/-/_}"
+DESCRIPTION="An XML parser for Ruby, in Ruby"
+HOMEPAGE="http://www.germane-software.com/software/rexml"
+SRC_URI="http://www.germane-software.com/archives/${MY_P}.tgz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~hppa ~mips ~sparc ~x86"
+USE_RUBY="any"
+DEPEND="virtual/ruby"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ ruby bin/install.rb --destdir=${D} || die
+ dodoc README
+ # Use insinto/doins to avoid compressing html files
+ insinto /usr/share/doc/${P}
+ doins *.html
+ dohtml -r doc/*
+}