summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hxd/hxd-0.70.02-r1.ebuild')
-rw-r--r--dev-util/hxd/hxd-0.70.02-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/hxd/hxd-0.70.02-r1.ebuild b/dev-util/hxd/hxd-0.70.02-r1.ebuild
new file mode 100644
index 000000000000..38c5e6dc4b0b
--- /dev/null
+++ b/dev-util/hxd/hxd-0.70.02-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/hxd/hxd-0.70.02-r1.ebuild,v 1.1 2012/06/20 12:53:28 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Binary to hexadecimal converter"
+HOMEPAGE="http://www-tet.ee.tu-berlin.de/solyga/linux/"
+SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~mips ~ppc"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-prll-flags.patch \
+ "${FILESDIR}"/${P}-llong-redef.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin hxd unhxd
+ doman hxd.1 unhxd.1
+ dodoc README TODO
+}