summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/moagg/moagg-0.12.ebuild')
-rw-r--r--games-arcade/moagg/moagg-0.12.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/games-arcade/moagg/moagg-0.12.ebuild b/games-arcade/moagg/moagg-0.12.ebuild
index fb607cab656d..3f65a8582072 100644
--- a/games-arcade/moagg/moagg-0.12.ebuild
+++ b/games-arcade/moagg/moagg-0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/moagg/moagg-0.12.ebuild,v 1.1 2004/07/25 11:48:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/moagg/moagg-0.12.ebuild,v 1.2 2004/07/26 10:27:17 mr_bones_ Exp $
inherit eutils games
@@ -26,6 +26,15 @@ src_unpack() {
epatch "${FILESDIR}/${PV}-Makefile.in.patch"
}
+src_compile() {
+ egamesconf \
+ --disable-sdltest \
+ --disable-freetypetest \
+ --disable-paraguitest \
+ --disable-testsuite || die
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README TODO doc/*.tex