summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xmille/xmille-2.0-r2.ebuild')
-rw-r--r--games-board/xmille/xmille-2.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/xmille/xmille-2.0-r2.ebuild b/games-board/xmille/xmille-2.0-r2.ebuild
new file mode 100644
index 000000000000..756eb5b85735
--- /dev/null
+++ b/games-board/xmille/xmille-2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xmille/xmille-2.0-r2.ebuild,v 1.1 2013/01/22 17:23:31 hasufell Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DEB_PATCH_VER="12"
+DESCRIPTION="Mille Bournes card game"
+HOMEPAGE="http://www.milleborne.info/"
+SRC_URI="mirror://debian/pool/main/x/xmille/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/xmille/${PN}_${PV}-${DEB_PATCH_VER}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake"
+
+S=${WORKDIR}/${P}.orig
+
+PATCHES=( "${WORKDIR}"/${PN}_${PV}-${DEB_PATCH_VER}.diff )
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake -j1 \
+ AR="$(tc-getAR) clq" \
+ RANLIB="$(tc-getRANLIB)" \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dogamesbin xmille
+ dodoc CHANGES README
+ newman xmille.man xmille.6
+ prepgamesdirs
+}