summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/qtads')
-rw-r--r--games-engines/qtads/ChangeLog7
-rw-r--r--games-engines/qtads/qtads-2.1.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/games-engines/qtads/ChangeLog b/games-engines/qtads/ChangeLog
index 5986801e2e1b..9447325a86de 100644
--- a/games-engines/qtads/ChangeLog
+++ b/games-engines/qtads/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/qtads
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/ChangeLog,v 1.12 2011/02/02 09:29:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/ChangeLog,v 1.13 2011/02/20 21:22:37 mr_bones_ Exp $
+
+*qtads-2.1.1 (20 Feb 2011)
+
+ 20 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org> +qtads-2.1.1.ebuild:
+ version bump
*qtads-2.1.0 (02 Feb 2011)
diff --git a/games-engines/qtads/qtads-2.1.1.ebuild b/games-engines/qtads/qtads-2.1.1.ebuild
new file mode 100644
index 000000000000..aadcd53e7639
--- /dev/null
+++ b/games-engines/qtads/qtads-2.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/qtads/qtads-2.1.1.ebuild,v 1.1 2011/02/20 21:22:37 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils qt4-r2 games
+
+DESCRIPTION="Multimedia interpreter for TADS text adventures"
+HOMEPAGE="http://qtads.sourceforge.net"
+SRC_URI="mirror://sourceforge/qtads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/qt-gui:4
+ media-libs/libsdl[audio]
+ media-libs/sdl-mixer[midi,vorbis]
+ media-libs/sdl-sound[mp3]"
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ dogamesbin qtads || die
+ doman qtads.6
+ dodoc AUTHORS BUGS NEWS README
+ make_desktop_entry qtads QTads
+ prepgamesdirs
+}