summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/openttd')
-rw-r--r--games-simulation/openttd/ChangeLog8
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.4.0.1-r12
-rw-r--r--games-simulation/openttd/files/digest-openttd-0.4.8_rc26
-rw-r--r--games-simulation/openttd/openttd-0.4.8_rc2.ebuild175
4 files changed, 190 insertions, 1 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index ef1c3de40fad..fa14ca122c68 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.22 2006/07/12 19:27:40 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.23 2006/08/07 01:07:15 robbat2 Exp $
+
+*openttd-0.4.8_rc2 (07 Aug 2006)
+
+ 07 Aug 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +openttd-0.4.8_rc2.ebuild:
+ Bump to rc2, with some ebuild cleanups, because rc1 kept crashing on me.
*openttd-0.4.8_rc1 (12 Jul 2006)
diff --git a/games-simulation/openttd/files/digest-openttd-0.4.0.1-r1 b/games-simulation/openttd/files/digest-openttd-0.4.0.1-r1
index 1272ae79fcdd..74af8f139244 100644
--- a/games-simulation/openttd/files/digest-openttd-0.4.0.1-r1
+++ b/games-simulation/openttd/files/digest-openttd-0.4.0.1-r1
@@ -1 +1,3 @@
MD5 ddd9790c86b7ccc68f60761704cbcf81 openttd-0.4.0.1-source.tar.gz 2950778
+RMD160 4bd07812c27cf7a637feaf92ee66ccdff56c6b65 openttd-0.4.0.1-source.tar.gz 2950778
+SHA256 56e844da580761ddbb580683fc455a8d9eb3179df631568c26b7188d1ff16363 openttd-0.4.0.1-source.tar.gz 2950778
diff --git a/games-simulation/openttd/files/digest-openttd-0.4.8_rc2 b/games-simulation/openttd/files/digest-openttd-0.4.8_rc2
new file mode 100644
index 000000000000..3992765ec6c6
--- /dev/null
+++ b/games-simulation/openttd/files/digest-openttd-0.4.8_rc2
@@ -0,0 +1,6 @@
+MD5 34e8cb13ce1d4e6b5b24887c628c1ac8 openttd-0.4.8-RC2-scenarios.tar.bz2 5000799
+RMD160 a6c2fa9f81e4e4628adb9c3932dec46ab4789777 openttd-0.4.8-RC2-scenarios.tar.bz2 5000799
+SHA256 61788035bd78a3c0e393d5992432c37e0b6036d19a960543f26d43a46e39e6ca openttd-0.4.8-RC2-scenarios.tar.bz2 5000799
+MD5 c1149d6258f43eb6645ebf2d6a26e0b7 openttd-0.4.8-RC2-source.tar.bz2 2211442
+RMD160 59a66b05ce563a1c5d12b0f5ebe4bee818c8fe94 openttd-0.4.8-RC2-source.tar.bz2 2211442
+SHA256 f9e791b57a19b8e9889a620d1d46a5400c1b45dfbf2659a3dbead8de4d3a8c73 openttd-0.4.8-RC2-source.tar.bz2 2211442
diff --git a/games-simulation/openttd/openttd-0.4.8_rc2.ebuild b/games-simulation/openttd/openttd-0.4.8_rc2.ebuild
new file mode 100644
index 000000000000..4cf9a486c798
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.4.8_rc2.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.4.8_rc2.ebuild,v 1.1 2006/08/07 01:07:15 robbat2 Exp $
+
+inherit eutils games
+
+MY_PV="${PV/_rc/-RC}"
+MY_P="${PN}-${MY_PV}"
+# At some point in the future this may be needed again
+# as upstream doesn't re-upload scenarios if they don't change.
+#SCENARIO_PV="0.4.7"
+SCENARIOS_A="${MY_P}-scenarios.tar.bz2"
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.com/"
+SB="mirror://sourceforge/openttd"
+SRC_URI="${SB}/${MY_P}-source.tar.bz2
+ scenarios? ( ${SB}/${SCENARIOS_A} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug png zlib timidity alsa dedicated scenarios"
+
+DEPEND="!dedicated? ( media-libs/libsdl )
+ png? ( media-libs/libpng )
+ scenarios? ( app-arch/unzip )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ !dedicated? (
+ timidity? ( media-sound/timidity++ )
+ !timidity? ( alsa? ( media-sound/alsa-utils ) )
+ )"
+
+S="${WORKDIR}/${P/_rc/-RC}"
+
+src_unpack() {
+ unpack ${MY_P}-source.tar.bz2
+ if use scenarios; then
+ cd ${S}/scenario/
+ unpack ${SCENARIOS_A}
+ fi
+ cd ${S}
+}
+
+src_compile() {
+ local myopts=""
+ use debug && myopts="${myopts} DEBUG=1"
+ use dedicated && myopts="${myopts} DEDICATED=1"
+ use png && myopts="${myopts} WITH_PNG=1"
+ use zlib && myopts="${myopts} WITH_ZLIB=1"
+ if ! use dedicated; then
+ myopts="${myopts} WITH_SDL=1"
+ if ! use timidity; then
+ use alsa && myopts="${myopts} MIDI=/usr/bin/aplaymidi"
+ fi
+ fi
+
+ # parallel build not supported
+ emake -j1 \
+ MANUAL_CONFIG=1 \
+ UNIX=1 \
+ WITH_NETWORK=1 \
+ INSTALL=1 \
+ RELEASE=${PV} \
+ USE_HOMEDIR=1 \
+ PERSONAL_DIR=.openttd \
+ PREFIX=/usr \
+ DATA_DIR=share/games/${PN} \
+ ${myopts} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin openttd || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed (data)"
+
+ insinto "${GAMES_DATADIR}/${PN}/lang"
+ doins lang/*.lng || die "doins failed (lang)"
+
+ if use scenarios; then
+ insinto "${GAMES_DATADIR}/${PN}/scenario"
+ doins scenario/* || die "doins failed (scenario)"
+ fi
+
+ insinto "${GAMES_DATADIR}/${PN}/scripts"
+ doins scripts/*.example || die "doins failed (scripts)"
+
+ for i in {16,32,48,64,128}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/apps
+ newins media/openttd.${i}.png openttd.png
+ done
+
+ if ! use dedicated; then
+ if use timidity || use alsa; then
+ make_desktop_entry "openttd -m extmidi" "OpenTTD" openttd
+ else
+ make_desktop_entry openttd "OpenTTD" openttd
+ fi
+ else
+ newinitd "${FILESDIR}"/openttd.initd openttd
+ fi
+
+ dodoc readme.txt known-bugs.txt changelog.txt docs/Manual.txt docs/console.txt docs/multiplayer.txt
+ newdoc scripts/readme.txt readme_scripts.txt
+ doman docs/openttd.6
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ einfo "In order to play, you must copy the following 6 files from "
+ einfo "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+ echo
+ einfo "From the WINDOWS version you need: "
+ einfo " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ einfo "OR from the DOS version you need: "
+ einfo " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ echo
+ einfo "File names are case sensitive so make sure they are "
+ einfo "correct for whichever version you have."
+ echo
+
+ if ! use scenarios; then
+ einfo "Scenarios are now included in a seperate package. To "
+ einfo "install them as well please remerge with the "
+ einfo "\"scenarios\" USE flag."
+ echo
+ else
+ einfo "Scenarios are installed to ${GAMES_DATADIR}/${PN}/scenario,"
+ einfo "you will have to symlink them to ~/.openttd/scenario in order"
+ einfo "to use them."
+ einfo "Example:"
+ einfo " mkdir -p ~/.openttd/scenario"
+ einfo " ln -s ${GAMES_DATADIR}/${PN}/scenario/* ~/.openttd/scenario/"
+ echo
+ fi
+
+ if use dedicated; then
+ einfo "You have chosen the dedicated USE flag which builds a "
+ einfo "version of OpenTTD to be used as a game server which "
+ einfo "does not require SDL. You will not be able to play the "
+ einfo "game, but if you don't pass this flag you can still use "
+ einfo "it as a server in the same way, but SDL will be required."
+ echo
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when run, including any running client sessions!"
+ echo
+ else
+ if use timidity || use alsa; then
+ einfo "If you want music, you must copy the gm/ directory"
+ einfo "to ${GAMES_DATADIR}/${PN}/"
+ einfo "You can enable MIDI by running:"
+ einfo " openttd -m extmidi"
+ echo
+ if use timidity; then
+ einfo "You also need soundfonts for timidity, if you don't"
+ einfo "know what that is, do:"
+ echo
+ einfo "emerge media-sound/timidity-eawpatches"
+ else
+ einfo "You have emerged with 'aplaymidi' for playing MIDI."
+ einfo "You have to set the environment variable ALSA_OUTPUT_PORTS."
+ einfo "Available ports can be listed by using 'aplaymidi -l'."
+ fi
+ else
+ einfo "timidity and/or alsa not in USE so music will not be played during the game."
+ fi
+ echo
+ fi
+}