summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/openxcom/openxcom-9999.ebuild')
-rw-r--r--games-strategy/openxcom/openxcom-9999.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/games-strategy/openxcom/openxcom-9999.ebuild b/games-strategy/openxcom/openxcom-9999.ebuild
index a7e715f8c886..5384630c757e 100644
--- a/games-strategy/openxcom/openxcom-9999.ebuild
+++ b/games-strategy/openxcom/openxcom-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/openxcom/openxcom-9999.ebuild,v 1.2 2011/11/05 10:59:19 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/openxcom/openxcom-9999.ebuild,v 1.3 2011/11/05 19:04:55 scarabeus Exp $
EAPI=3
@@ -16,15 +16,17 @@ HOMEPAGE="http://openxcom.org/"
LICENSE="GPL-3"
SLOT="0"
[[ ${PV} = 9999 ]] || KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="doc"
-DEPEND="
+RDEPEND="
dev-cpp/yaml-cpp
media-libs/libsdl
media-libs/sdl-gfx
media-libs/sdl-mixer
"
-RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
[[ ${PV} = 9999 ]] && eautoreconf
@@ -32,13 +34,18 @@ src_prepare() {
src_configure() {
egamesconf \
- --disable-werror
+ --disable-werror \
+ $(use_with doc docs)
}
src_install() {
emake DESTDIR="${ED}" install || die
+ if [[ -e "${S}"/ChangeLog ]]; then
+ dodoc "${S}"/ChangeLog || die "dodoc failed"
+ fi
+
elog "Remember to put X-Com data to proper location:"
- elog " ${ED}/usr/share/${PN}/"
+ elog " ${ED}/usr/share/${PN}/"
prepgamesdirs
}