summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/scorched3d/scorched3d-37.2.ebuild')
-rw-r--r--games-strategy/scorched3d/scorched3d-37.2.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/games-strategy/scorched3d/scorched3d-37.2.ebuild b/games-strategy/scorched3d/scorched3d-37.2.ebuild
index fc2598059d26..395c046d66ca 100644
--- a/games-strategy/scorched3d/scorched3d-37.2.ebuild
+++ b/games-strategy/scorched3d/scorched3d-37.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-37.2.ebuild,v 1.2 2004/06/24 23:28:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/scorched3d/scorched3d-37.2.ebuild,v 1.3 2004/07/04 09:59:14 mr_bones_ Exp $
inherit games
@@ -25,6 +25,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/scorched"
+pkg_setup() {
+ if wx-config --cppflags | grep gtk2u >& /dev/null; then
+ einfo "${PN} will not build if wxGTK was compiled"
+ einfo "with unicode support. If you are using a version of"
+ einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
+ einfo "you must set USE=-unicode."
+ die "wxGTK must be re-emerged without unicode suport"
+ fi
+}
+
src_compile() {
egamesconf \
--exec_prefix="${GAMES_PREFIX}" \