summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/gslist/gslist-0.8.2.ebuild')
-rw-r--r--games-util/gslist/gslist-0.8.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-util/gslist/gslist-0.8.2.ebuild b/games-util/gslist/gslist-0.8.2.ebuild
new file mode 100644
index 000000000000..4e24d7a6dcce
--- /dev/null
+++ b/games-util/gslist/gslist-0.8.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/gslist-0.8.2.ebuild,v 1.1 2007/01/04 19:29:07 nyhm Exp $
+
+inherit toolchain-funcs games
+
+DESCRIPTION="A GameSpy server browser"
+HOMEPAGE="http://aluigi.altervista.org/papers.htm#gslist"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i "s:gcc:$(tc-getCC):" Makefile || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ dodoc ${PN}.txt
+ prepgamesdirs
+}