summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kooka/files/configure-fix-kdegraphics-kadmos.patch')
-rw-r--r--kde-base/kooka/files/configure-fix-kdegraphics-kadmos.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-base/kooka/files/configure-fix-kdegraphics-kadmos.patch b/kde-base/kooka/files/configure-fix-kdegraphics-kadmos.patch
new file mode 100644
index 000000000000..1f0334b99ef9
--- /dev/null
+++ b/kde-base/kooka/files/configure-fix-kdegraphics-kadmos.patch
@@ -0,0 +1,47 @@
+Index: kooka/configure.in.in
+===================================================================
+--- kooka/configure.in.in (revision 428265)
++++ kooka/configure.in.in (working copy)
+@@ -2,21 +2,32 @@
+ dnl AC_CHECK_LIB(Pgm2asc,pgm2asc)
+ dnl should define HAVE_LIBPGM2ASC if available
+
+-AC_ARG_WITH(kadmos-dir,
+-AC_HELP_STRING([--with-kadmos-dir],[sets the path to the kadmos engine]),
+- [ac_kadmos_value=$withval], [ac_kadmos_value=NONE])
++AC_ARG_WITH([kadmos],
++ [AS_HELP_STRING([--with-kadmos],
++ [Enable the kadmos OCR engine @<:@default=check@:>@])],
++ [], with_kadmos=check)
+
++AC_ARG_WITH([kadmos-dir],
++ AS_HELP_STRING([--with-kadmos-dir],
++ [sets the path to the kadmos engine @<:@default=/usr/local@:>@]),
++ [ac_kadmos_value=$withval], [ac_kadmos_value=/usr/local])
++
+ KADMOS_INC=
+ KADMOS_LIB=
+
+-if test -r "$ac_kadmos_value/kadmos.h"; then
+- KADMOS_INC="-I$ac_kadmos_value"
+- KADMOS_LIB="$ac_kadmos_value/librep.a"
+- AC_DEFINE_UNQUOTED(HAVE_KADMOS, 1, [Defines if your system has the kadmos libraries])
+-elif test ! "x$ac_kadmos_value" = "xNONE"; then
+- AC_MSG_WARN([couldn't find kadmos engine header file under $ac_kadmos_value/kadmos.h])
++if test "x$with_kadmos" != xno; then
++ if test -r "$ac_kadmos_value/kadmos.h"; then
++ KADMOS_INC="-I$ac_kadmos_value"
++ KADMOS_LIB="$ac_kadmos_value/librep.a"
++ AC_DEFINE_UNQUOTED(HAVE_KADMOS, 1, [Defines if your system has the kadmos libraries])
++ else
++ AC_MSG_WARN([couldn't find kadmos engine header file under $ac_kadmos_value/kadmos.h])
++ fi
++
++ if test "x$with_kadmos" != xcheck && test -z "$KADMOS_LIB"; then
++ AC_MSG_FAILURE([--with-kadmos was given, but test for kadmos failed])
++ fi
+ fi
+
+ AC_SUBST(KADMOS_LIB)
+ AC_SUBST(KADMOS_INC)
+-