summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/etpan-ng/etpan-ng-0.7.1.ebuild')
-rw-r--r--mail-client/etpan-ng/etpan-ng-0.7.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail-client/etpan-ng/etpan-ng-0.7.1.ebuild b/mail-client/etpan-ng/etpan-ng-0.7.1.ebuild
new file mode 100644
index 000000000000..54effd8d7713
--- /dev/null
+++ b/mail-client/etpan-ng/etpan-ng-0.7.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/etpan-ng/etpan-ng-0.7.1.ebuild,v 1.1 2006/01/11 08:41:37 ticho Exp $
+
+DESCRIPTION="etPan is a console mail client that is based on libEtPan!"
+HOMEPAGE="http://libetpan.sourceforge.net/etpan/"
+SRC_URI="mirror://sourceforge/libetpan/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ldap"
+
+DEPEND=">=net-libs/libetpan-0.35
+ sys-libs/ncurses
+ ldap? ( net-nds/openldap )"
+
+src_compile() {
+ sed -i -e "s:@bindir@:${D}/@bindir@:" src/Makefile.in
+
+ econf \
+ `use_enable debug` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc Changelog NEWS README TODO contrib/etpan-make-vtree.pl doc/*
+}