summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/farsight/farsight-0.1.18.ebuild')
-rw-r--r--media-libs/farsight/farsight-0.1.18.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/farsight/farsight-0.1.18.ebuild b/media-libs/farsight/farsight-0.1.18.ebuild
new file mode 100644
index 000000000000..2f9da144b3d0
--- /dev/null
+++ b/media-libs/farsight/farsight-0.1.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/farsight/farsight-0.1.18.ebuild,v 1.1 2007/04/30 22:08:59 tester Exp $
+
+DESCRIPTION="FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE="http://farsight.freedesktop.org/"
+SRC_URI="http://farsight.freedesktop.org/releases/${PN}/${P}.tar.gz"
+#EDARCS_REPO_URI="http://projects.collabora.co.uk/darcs/farsight/farsight"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="jingle doc"
+# msn yahoo
+SLOT="0"
+
+RDEPEND="=media-libs/gstreamer-0.10*
+ >=media-plugins/gst-plugins-farsight-0.12.0
+ >=dev-libs/glib-2.6
+ dev-libs/libxml2
+ doc? ( >=dev-util/gtk-doc-1.5 )
+ jingle? ( >=net-libs/libjingle-0.3.11 )"
+ # Next version has unit tests
+ #test? ( >=dev-libs/check-0.9.4 ) "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ # I'm disabling clinkc because it sucks, isnt in portage
+ # and I couldnt care less for upnp
+ econf --enable-rtp \
+ --disable-clinkc \
+ $(use_enable doc) \
+ $(use_enable jingle jingle-p2p) || die "econf failed"
+ # Not yet ported to the new version
+ # $(use_enable msn msnwebcam) \
+ # $(use_enable msn msnavconf) \
+ # $(use_enable yahoo yahoowebcam) \
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README TODO
+}