summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libtheora/libtheora-1.0_alpha4.ebuild')
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/libtheora/libtheora-1.0_alpha4.ebuild b/media-libs/libtheora/libtheora-1.0_alpha4.ebuild
new file mode 100644
index 000000000000..9055acd5c5b8
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha4.ebuild,v 1.1 2005/01/01 05:56:40 chriswhite Exp $
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libogg-1.1.0
+ >=media-libs/libvorbis-1.0.1"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.in
+}
+
+src_compile() {
+ econf --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ dodoc README
+}