summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libwmf/libwmf-0.2.8.2.ebuild')
-rw-r--r--media-libs/libwmf/libwmf-0.2.8.2.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/media-libs/libwmf/libwmf-0.2.8.2.ebuild b/media-libs/libwmf/libwmf-0.2.8.2.ebuild
deleted file mode 100644
index 9f808a8f1c5f..000000000000
--- a/media-libs/libwmf/libwmf-0.2.8.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libwmf/libwmf-0.2.8.2.ebuild,v 1.11 2006/01/16 09:28:52 vapier Exp $
-
-inherit libtool
-
-#The configure script finds the 5.50 ghostscript Fontmap file while run.
-#This will probably work, especially since the real one (6.50) in this case
-#is empty. However beware in case there is any trouble
-
-DESCRIPTION="library for converting WMF files"
-HOMEPAGE="http://wvware.sourceforge.net/"
-SRC_URI="mirror://sourceforge/wvware/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
-IUSE="jpeg X"
-
-DEPEND="virtual/ghostscript
- dev-libs/expat
- dev-libs/libxml2
- >=media-libs/freetype-2.0.1
- sys-libs/zlib
- media-libs/libpng
- jpeg? ( media-libs/jpeg )
- X? ( virtual/x11 )"
-# plotutils are not really supported yet, so looks like that's it
-
-src_compile() {
- # Have to use the reverse-deps patch to prevent libwmf from
- # linking an older installed version of libwmflite
- #still needed !? <vapier@gentoo.org>
- #elibtoolize --reverse-deps
-
- use jpeg || myconf="${myconf} --with-jpeg=no"
- use X || myconf="${myconf} --with-x=no"
- econf \
- ${myconf} \
- --with-gsfontdir=/usr/share/ghostscript/fonts \
- --with-fontdir=/usr/share/libwmf/fonts/ \
- --with-docdir=/usr/share/doc/${PF} \
- || die "./configure failed"
-
- emake || die
-}
-
-src_install () {
- make install \
- DESTDIR=${D} \
- fontdir=/usr/share/libwmf/fonts \
- wmfonedocdir=/usr/share/doc/${PF}/caolan \
- wmfdocdir=/usr/share/doc/${PF} \
- || die
- dodoc README AUTHORS COPYING CREDITS ChangeLog NEWS TODO
-}