summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ecasound/ecasound-2.4.1.ebuild')
-rw-r--r--media-sound/ecasound/ecasound-2.4.1.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/media-sound/ecasound/ecasound-2.4.1.ebuild b/media-sound/ecasound/ecasound-2.4.1.ebuild
deleted file mode 100644
index 06283b945abb..000000000000
--- a/media-sound/ecasound/ecasound-2.4.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ecasound/ecasound-2.4.1.ebuild,v 1.3 2005/09/04 10:37:58 flameeyes Exp $
-
-IUSE="ncurses arts alsa python oss mikmod oggvorbis jack audiofile"
-
-DESCRIPTION="A package for multitrack audio processing"
-SRC_URI="http://ecasound.seul.org/download/${P}.tar.gz"
-HOMEPAGE="http://eca.cx/"
-LICENSE="GPL-2"
-
-SLOT="1"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc-macos"
-
-DEPEND="jack? ( media-sound/jack-audio-connection-kit )
- media-libs/ladspa-sdk
- audiofile? ( media-libs/audiofile )
- alsa? ( media-libs/alsa-lib )
- oggvorbis? ( media-libs/libvorbis )
- arts? ( kde-base/arts )
- mikmod? ( media-libs/libmikmod )
- python? ( dev-lang/python )
- ncurses? ( sys-libs/ncurses )"
-
-# We don't make RDEPEND for vorbis-tools, mpg123/mpg321, timidity++ or lame -- no
-# use flags for them.
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i 's:map.h:map:g' configure
-}
-
-src_compile () {
- local myconf
-
- use jack || myconf="$myconf --disable-jack"
- use alsa || myconf="$myconf --disable-alsa"
- use arts || myconf="$myconf --disable-arts"
- use ncurses || myconf="$myconf --disable-ncurses"
- use audiofile || myconf="$myconf --disable-audiofile"
- use oss || myconf="$myconf --disable-oss"
-
- use amd64 && myconf="${myconf} --with-pic"
-
- if use python; then
- #
- # ecasound is braindead about finding python includes/libdirs and
- # about where to install modules. Luckily, it allows us to specify
- # all this.
- #
- local python_version python_prefix python_includes python_modules
- python_version="`python -c 'import sys; print sys.version[:3]'`"
- python_prefix="`python -c 'import sys; print sys.prefix'`"
-
- python_includes="$python_prefix/include/python$python_version"
- python_modules="$python_prefix/lib/python$python_version"
-
- myconf="$myconf --with-python-includes=$python_includes"
- myconf="$myconf --with-python-modules=$python_modules"
- else
- myconf="$myconf --disable-pyecasound"
- fi
-
- einfo "configuring with ${myconf}"
- econf ${myconf} || die "configure failed"
- make || die "build failed"
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-
- if use python; then
- cd pyecasound || die
- python -c "import compileall; compileall.compile_dir('.')" || die
- python -O -c "import compileall; compileall.compile_dir('.')" || die
- python_sitepkgsdir="`python -c "import sys; print (sys.prefix + '/lib/python' + sys.version[:3] + '/site-packages/')"`"
- install *.pyc *.pyo "${D}/${python_sitepkgsdir}"
- cd ..
- fi
-
- dodoc FAQ BUGS NEWS README TODO
- dohtml `find Documentation -name "*.html"`
- dodoc Documentation/edi-list.txt
-}
-
-pkg_postinst() {
- if use arts; then
- ewarn "WARNING: You have requested ecasound ARTS support,"
- ewarn "this is no longer supported and may go away in"
- ewarn "future releases."
- fi
-}