summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/gpac/gpac-0.5.0.ebuild')
-rw-r--r--media-video/gpac/gpac-0.5.0.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/media-video/gpac/gpac-0.5.0.ebuild b/media-video/gpac/gpac-0.5.0.ebuild
index a297628ff4a5..b05f94e98905 100644
--- a/media-video/gpac/gpac-0.5.0.ebuild
+++ b/media-video/gpac/gpac-0.5.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/gpac-0.5.0.ebuild,v 1.10 2013/08/14 20:51:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/gpac-0.5.0.ebuild,v 1.11 2013/08/14 21:00:49 aballier Exp $
EAPI=4
-inherit eutils wxwidgets flag-o-matic multilib toolchain-funcs
+inherit eutils flag-o-matic multilib toolchain-funcs
DESCRIPTION="GPAC is an implementation of the MPEG-4 Systems standard developed from scratch in ANSI C."
HOMEPAGE="http://gpac.wp.mines-telecom.fr/"
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="a52 aac alsa debug dvb ffmpeg ipv6 jack jpeg jpeg2k mad opengl oss png pulseaudio sdl ssl static-libs theora truetype vorbis wxwidgets xml xvid"
+IUSE="a52 aac alsa debug dvb ffmpeg ipv6 jack jpeg jpeg2k mad opengl oss png pulseaudio sdl ssl static-libs theora truetype vorbis xml xvid"
S="${WORKDIR}"/${PN}
@@ -32,7 +32,6 @@ RDEPEND="
vorbis? ( >=media-libs/libvorbis-1.1 )
theora? ( media-libs/libtheora )
truetype? ( >=media-libs/freetype-2.1.4 )
- wxwidgets? ( =x11-libs/wxGTK-2.8* )
xml? ( >=dev-libs/libxml2-2.6.0 )
xvid? ( >=media-libs/xvid-1.0.1 )
sdl? ( media-libs/libsdl )
@@ -43,6 +42,8 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXv
x11-libs/libXext"
+# disabled upstream, see applications/Makefile
+# wxwidgets? ( =x11-libs/wxGTK-2.8* )
DEPEND="${RDEPEND}"
@@ -74,13 +75,13 @@ src_prepare() {
chmod +x configure
# make sure configure looks for wx without needing eselect set
- if use wxwidgets; then
- WX_GTK_VER=2.8
- need-wxwidgets unicode
- sed -i -e "s:wx-config:${WX_CONFIG}:g" configure || die
- else
- sed -i -e "s:wx-config:wx-config-doesnotexist:g" configure || die
- fi
+ # if use wxwidgets; then
+ # WX_GTK_VER=2.8
+ # need-wxwidgets unicode
+ # sed -i -e "s:wx-config:${WX_CONFIG}:g" configure || die
+ #else
+ # sed -i -e "s:wx-config:wx-config-doesnotexist:g" configure || die
+ #fi
}
src_configure() {
@@ -102,7 +103,7 @@ src_configure() {
$(use_enable sdl) \
$(use_enable ssl) \
$(use_enable static-libs static-lib) \
- $(use_enable wxwidgets wx) \
+ --disable-wx \
$(my_use a52) \
$(my_use aac faad) \
$(my_use dvb dvbx) \