summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/xine-ui/xine-ui-0.9.11.ebuild')
-rw-r--r--media-video/xine-ui/xine-ui-0.9.11.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-video/xine-ui/xine-ui-0.9.11.ebuild b/media-video/xine-ui/xine-ui-0.9.11.ebuild
new file mode 100644
index 000000000000..941f801f6efd
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.11.ebuild,v 1.1 2002/06/20 21:20:20 agenkin Exp $
+
+DESCRIPTION="Xine is a free gpl-licensed video player for unix-like systems"
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL"
+
+DEPEND="virtual/glibc
+ media-libs/libpng
+ >=media-libs/xine-lib-${PV}
+ nls? ( sys-devel/gettext )
+ X? ( virtual/x11 )
+ directfb? ( >=dev-libs/DirectFB-0.9.9 )
+ gnome? ( gnome-base/ORBit )"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+
+SRC_URI="http://xine.sourceforge.net/files/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}