summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/authforce/authforce-0.9.9-r1.ebuild')
-rw-r--r--net-analyzer/authforce/authforce-0.9.9-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/authforce/authforce-0.9.9-r1.ebuild b/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..7a5efde42c65
--- /dev/null
+++ b/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/authforce/authforce-0.9.9-r1.ebuild,v 1.1 2011/11/12 14:34:07 xmw Exp $
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="An HTTP authentication brute forcer"
+HOMEPAGE="http://www.divineinvasion.net/authforce"
+SRC_URI="http://www.divineinvasion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl nls"
+DEPEND="sys-libs/readline
+ nls? ( sys-devel/gettext )
+ curl? ( net-misc/curl )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO )
+PATCHES=( "${FILESDIR}"/${P}-curl.patch )
+
+src_configure() {
+ econf \
+ $(use_with curl) \
+ $(use_enable nls) \
+ --with-path=/usr/share/${PN}/data:.
+}