summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/flowgrind/flowgrind-0.5.8.ebuild')
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.5.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/flowgrind/flowgrind-0.5.8.ebuild b/net-analyzer/flowgrind/flowgrind-0.5.8.ebuild
new file mode 100644
index 000000000000..52d9c6f874b3
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.5.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flowgrind/flowgrind-0.5.8.ebuild,v 1.1 2012/03/18 22:42:58 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://www.umic-mesh.net/research/flowgrind"
+SRC_URI="http://www.umic-mesh.net/downloads/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gsl pcap"
+
+RDEPEND="dev-libs/xmlrpc-c[abyss,curl]
+ gsl? ( sci-libs/gsl )
+ pcap? ( sys-libs/libcap )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gsl) \
+ $(use_enable pcap)
+}