summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hping')
-rw-r--r--net-analyzer/hping/ChangeLog13
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch16
-rw-r--r--net-analyzer/hping/files/hping-3_pre20051105-tcl.patch11
-rw-r--r--net-analyzer/hping/hping-3_pre20051105-r1.ebuild63
-rw-r--r--net-analyzer/hping/hping-3_pre20051105.ebuild6
5 files changed, 104 insertions, 5 deletions
diff --git a/net-analyzer/hping/ChangeLog b/net-analyzer/hping/ChangeLog
index eec629c44ebf..26e263d10989 100644
--- a/net-analyzer/hping/ChangeLog
+++ b/net-analyzer/hping/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-analyzer/hping
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.44 2007/09/06 16:42:08 jokey Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.45 2009/12/22 20:26:02 jer Exp $
+
+*hping-3_pre20051105-r1 (22 Dec 2009)
+
+ 22 Dec 2009; Jeroen Roovers <jer@gentoo.org> hping-3_pre20051105.ebuild,
+ +hping-3_pre20051105-r1.ebuild, +files/hping-3_pre20051105-ldflags.patch,
+ +files/hping-3_pre20051105-tcl.patch:
+ Add tcl8.5 patch (stupid configure script). Respect LDFLAGS. Call epatch
+ just once. Call sed just once. Respect libdir. Do not call econf but
+ configure. Readd mysteriously disappearing keywords.
06 Sep 2007; Markus Ullmann <jokey@gentoo.org> -hping-2.0.0_rc2-r1.ebuild,
-hping-2.0.0_rc3.ebuild:
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
new file mode 100644
index 000000000000..125db3345e02
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-ldflags.patch
@@ -0,0 +1,16 @@
+--- Makefile.in.org 2009-12-22 21:06:55.000000000 +0100
++++ Makefile.in 2009-12-22 21:09:17.000000000 +0100
+@@ -50,11 +50,11 @@
+ $(RANLIB) $@
+
+ hping3: byteorder.h $(OBJ)
+- $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
++ $(CC) -o hping3 $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@
+ @echo
+
+ hping3-static: byteorder.h $(OBJ)
+- $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
++ $(CC) -static -o hping3-static $(CCOPT) $(LDFLAGS) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) @SOLARISLIB@ @TCL_LIB@ -ldl
+
+ byteorder.h:
+ ./configure
diff --git a/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch b/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch
new file mode 100644
index 000000000000..ae1525b64fa4
--- /dev/null
+++ b/net-analyzer/hping/files/hping-3_pre20051105-tcl.patch
@@ -0,0 +1,11 @@
+--- configure.org 2009-12-22 21:05:11.000000000 +0100
++++ configure 2009-12-22 21:06:07.000000000 +0100
+@@ -63,7 +63,7 @@
+ #
+ for TCLPATH_TRY in "/usr/bin/" "/usr/local/bin/" "/bin/"
+ do
+- for TCLVER_TRY in "8.4" "8.3" "8.2" "8.1" "8.0"
++ for TCLVER_TRY in "8.5" "8.4" "8.3" "8.2" "8.1" "8.0"
+ do
+ if [ -z $TCLSH ]
+ then
diff --git a/net-analyzer/hping/hping-3_pre20051105-r1.ebuild b/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
new file mode 100644
index 000000000000..29f87150b579
--- /dev/null
+++ b/net-analyzer/hping/hping-3_pre20051105-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105-r1.ebuild,v 1.1 2009/12/22 20:26:02 jer Exp $
+
+inherit eutils multilib toolchain-funcs
+
+MY_P="${PN}${PV//_pre/-}"
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="tcl debug"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="net-libs/libpcap
+ tcl? ( dev-lang/tcl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch \
+ "${FILESDIR}"/${P}.patch \
+ "${FILESDIR}"/bytesex.h.patch \
+ "${FILESDIR}"/${P}-tcl.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+
+ # Correct hard coded values
+ sed -i Makefile.in \
+ -e "9s:gcc:$(tc-getCC):" \
+ -e "10s:/usr/bin/ar:$(tc-getAR):" \
+ -e "11s:/usr/bin/ranlib:$(tc-getRANLIB):" \
+ -e "s:/usr/local/lib:/usr/$(get_libdir):g" \
+ -e "12s:-O2:${CFLAGS}:"
+}
+
+src_compile() {
+ myconf=""
+ use tcl || myconf="--no-tcl"
+
+ # Not an autotools type configure:
+ sh configure ${myconf} || die "configure failed"
+
+ if use debug; then
+ emake || die "make failed"
+ else
+ emake DEBUG="" || die "make failed"
+ fi
+}
+
+src_install () {
+ dosbin hping3
+ dosym /usr/sbin/hping3 /usr/sbin/hping
+ dosym /usr/sbin/hping3 /usr/sbin/hping2
+
+ doman docs/hping3.8
+
+ dodoc INSTALL NEWS README TODO AUTHORS BUGS CHANGES
+}
diff --git a/net-analyzer/hping/hping-3_pre20051105.ebuild b/net-analyzer/hping/hping-3_pre20051105.ebuild
index 8f079c1f9389..5f1af9aaad46 100644
--- a/net-analyzer/hping/hping-3_pre20051105.ebuild
+++ b/net-analyzer/hping/hping-3_pre20051105.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105.ebuild,v 1.4 2007/07/30 16:25:59 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-3_pre20051105.ebuild,v 1.5 2009/12/22 20:26:02 jer Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
IUSE="tcl debug"
S="${WORKDIR}/${MY_P}"