summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-1.1.0.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-1.1.0.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/net-analyzer/wireshark/wireshark-1.1.0.ebuild b/net-analyzer/wireshark/wireshark-1.1.0.ebuild
index 6114a92ea6df..847c512e728d 100644
--- a/net-analyzer/wireshark/wireshark-1.1.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.1.0.ebuild,v 1.1 2008/09/17 14:27:39 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.1.0.ebuild,v 1.2 2008/09/18 07:52:56 pva Exp $
EAPI=1
WANT_AUTOMAKE="1.9"
@@ -32,7 +32,7 @@ RDEPEND="zlib? ( sys-libs/zlib )
pcap? ( net-libs/libpcap )
pcre? ( dev-libs/libpcre )
caps? ( sys-libs/libcap )
- c-ares? ( net-dns/c-ares )
+ c-ares? ( >=net-dns/c-ares-1.5 )
!c-ares? ( adns? ( net-libs/adns ) )
kerberos? ( virtual/krb5 )
portaudio? ( media-libs/portaudio )
@@ -55,10 +55,8 @@ pkg_setup() {
if use c-ares && use adns; then
einfo "c-ares supersedes adns resolver. Using c-ares."
myconf="$(use_with c-ares) --without-adns"
- elif use adns; then
- myconf="$(use_with adns) --without-c-ares"
else
- myconf="--without-adns --without-c-ares" # disable automatic detection
+ myconf="$(use_with adns) $(use_with c-ares)"
fi
# Add group for users allowed to sniff.