summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/lftp/lftp-2.3.3.ebuild')
-rw-r--r--net-ftp/lftp/lftp-2.3.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-ftp/lftp/lftp-2.3.3.ebuild b/net-ftp/lftp/lftp-2.3.3.ebuild
new file mode 100644
index 000000000000..e5e4c9a2939b
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.3.3.ebuild,v 1.1 2000/10/05 00:13:01 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Groovy little ftp client"
+SRC_URI="ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${A}
+ http://metalab.unc.edu/pub/Linux/system/network/file-transfer/${A}"
+
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+src_unpack () {
+ unpack ${A}
+}
+
+src_compile() {
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+ try ./configure --prefix=/usr --sysconfdir=/etc/lftp --with-catgets --with-modules
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr sysconfdir=${D}/etc/lftp install
+ prepman
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS NEWS
+ dodoc README* THANKS TODO
+
+}
+
+
+
+
+