summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup/libsoup-2.2.3-r1.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-2.2.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libsoup/libsoup-2.2.3-r1.ebuild b/net-libs/libsoup/libsoup-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..1f22cab3ba01
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.2.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.2.3-r1.ebuild,v 1.1 2005/05/30 08:13:24 leonardop Exp $
+
+inherit gnome2
+
+DESCRIPTION="Soup is a SOAP implementation"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc ssl static"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/libxml2-2
+ ssl? ( >=net-libs/gnutls-1
+ >=dev-libs/libgpg-error-0.4 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog README* TODO"
+
+G2CONF="${G2CONF} $(use_enable ssl) $(use_enable static) \
+$(use_enable static static-ssl)"
+