summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild')
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild b/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild
deleted file mode 100644
index 5077674ef383..000000000000
--- a/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p42162.ebuild,v 1.3 2009/05/15 08:43:36 aballier Exp $
-
-EAPI=2
-
-inherit autotools flag-o-matic eutils
-
-MY_P="WebKit-r${PV/0\_p}"
-DESCRIPTION="Open source web browser engine"
-HOMEPAGE="http://www.webkit.org/"
-SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2 LGPL-2.1 BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 -ia64 ~ppc -sparc ~x86 ~x86-fbsd"
-IUSE="coverage debug gstreamer pango soup +sqlite svg xslt"
-
-RDEPEND=">=x11-libs/gtk+-2.8
- >=dev-libs/icu-3.8.1-r1
- >=net-misc/curl-7.15
- media-libs/jpeg
- media-libs/libpng
- dev-libs/libxml2
- sqlite? ( >=dev-db/sqlite-3 )
- gstreamer? (
- >=media-libs/gst-plugins-base-0.10
- )
- soup? ( >=net-libs/libsoup-2.26 )
- xslt? ( dev-libs/libxslt )
- pango? ( x11-libs/pango )"
-
-DEPEND="${RDEPEND}
- >=sys-devel/flex-2.5.33
- dev-util/gperf
- dev-util/pkgconfig
- virtual/perl-Text-Balanced
- dev-util/gtk-doc"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- AT_M4DIR=./autotools
- gtkdocize
- epatch "${FILESDIR}/${P}-gcc44-aliasing.patch"
- eautoreconf
-}
-
-src_configure() {
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- local myconf
- use pango && myconf="${myconf} --with-font-backend=pango"
- use soup && myconf="${myconf} --with-http-backend=soup"
-
- econf \
- $(use_enable sqlite database) \
- $(use_enable sqlite icon-database) \
- $(use_enable sqlite dom-storage) \
- $(use_enable sqlite offline-web-applications) \
- $(use_enable gstreamer video) \
- $(use_enable svg) \
- $(use_enable debug) \
- $(use_enable xslt) \
- $(use_enable coverage) \
- $(use_enable doc gtk-doc) \
- ${myconf} \
- || die "configure failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
-}