summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget/files/wget-1.11-linking.patch')
-rw-r--r--net-misc/wget/files/wget-1.11-linking.patch96
1 files changed, 0 insertions, 96 deletions
diff --git a/net-misc/wget/files/wget-1.11-linking.patch b/net-misc/wget/files/wget-1.11-linking.patch
deleted file mode 100644
index c1e20ebdca96..000000000000
--- a/net-misc/wget/files/wget-1.11-linking.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-For static linking, we need 2 things:
-1) lib-link.m4 should use -l<libname> and not <full path to lib>, else it tries
- to link against the .so
-2) lib-link.m4 should add $LIBS after the libs we test for, else newer ld's do
- not resolve symbols in static libs properly.
-
-Martin Schlemmer <azarah@gentoo.org>
-
---- configure
-+++ configure
-@@ -10304,5 +10304,5 @@
- if test "X$found_so" != "X"; then
- if test "$enable_rpath" = no || test "X$found_dir" = "X/usr/lib"; then
-- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
-+ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
- else
- haveit=
-@@ -10317,8 +10317,8 @@
- fi
- if test "$hardcode_direct" = yes; then
-- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
-+ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
- else
- if test -n "$hardcode_libdir_flag_spec" && test "$hardcode_minus_L" = no; then
-- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
-+ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
- haveit=
- for x in $rpathdirs; do
-@@ -10352,5 +10352,5 @@
- fi
- if test "$hardcode_minus_L" != no; then
-- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }$found_so"
-+ LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
- else
- LIBGNUTLS="${LIBGNUTLS}${LIBGNUTLS:+ }-l$name"
-@@ -10579,5 +10579,5 @@
-
- ac_save_LIBS="$LIBS"
-- LIBS="$LIBS $LIBGNUTLS"
-+ LIBS="$LIBGNUTLS $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
-@@ -10957,5 +10957,5 @@
- if test "X$found_so" != "X"; then
- if test "$enable_rpath" = no || test "X$found_dir" = "X/usr/lib"; then
-- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
-+ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
- else
- haveit=
-@@ -10970,8 +10970,8 @@
- fi
- if test "$hardcode_direct" = yes; then
-- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
-+ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
- else
- if test -n "$hardcode_libdir_flag_spec" && test "$hardcode_minus_L" = no; then
-- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
-+ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
- haveit=
- for x in $rpathdirs; do
-@@ -11005,5 +11005,5 @@
- fi
- if test "$hardcode_minus_L" != no; then
-- LIBSSL="${LIBSSL}${LIBSSL:+ }$found_so"
-+ LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
- else
- LIBSSL="${LIBSSL}${LIBSSL:+ }-l$name"
-@@ -11232,5 +11232,5 @@
-
- ac_save_LIBS="$LIBS"
-- LIBS="$LIBS $LIBSSL"
-+ LIBS="$LIBSSL $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
---- src/Makefile.in
-+++ src/Makefile.in
-@@ -53,7 +53,7 @@
- DEFS = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
- CFLAGS = @CFLAGS@
- LDFLAGS = @LDFLAGS@
--LIBS = @LIBS@ @LIBSSL@ @LIBGNUTLS@
-+LIBS = @LIBSSL@ @LIBGNUTLS@ @LIBS@
- exeext = @EXEEXT@
-
- INCLUDES = -I. -I$(srcdir)
---- Makefile.in
-+++ Makefile.in
-@@ -58,7 +58,7 @@
- CFLAGS = @CFLAGS@
- CPPFLAGS = @CPPFLAGS@
- DEFS = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
--LIBS = @LIBS@ @LIBSSL@ @LIBGNUTLS@
-+LIBS = @LIBSSL@ @LIBGNUTLS@ @LIBS@
- LDFLAGS = @LDFLAGS@
-
- #