summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vtun/ChangeLog9
-rw-r--r--net-misc/vtun/vtun-3.0.2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/net-misc/vtun/ChangeLog b/net-misc/vtun/ChangeLog
index 1db3f5681687..89bba0643ece 100644
--- a/net-misc/vtun/ChangeLog
+++ b/net-misc/vtun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/vtun
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.35 2008/04/21 18:07:24 phreak Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/ChangeLog,v 1.36 2009/04/19 17:23:02 rbu Exp $
+
+*vtun-3.0.2 (19 Apr 2009)
+
+ 19 Apr 2009; Robert Buchholz <rbu@gentoo.org> +vtun-3.0.2.ebuild:
+ Version bump, 3.0.2 adds compatibility to 2.x servers.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/net-misc/vtun/vtun-3.0.2.ebuild b/net-misc/vtun/vtun-3.0.2.ebuild
new file mode 100644
index 000000000000..130aaa4efe78
--- /dev/null
+++ b/net-misc/vtun/vtun-3.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vtun/vtun-3.0.2.ebuild,v 1.1 2009/04/19 17:23:02 rbu Exp $
+
+EAPI=2
+DESCRIPTION="Create virtual tunnels over TCP/IP networks with traffic shaping, encryption, and compression."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://vtun.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="lzo socks5 ssl zlib"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo:2 )
+ zlib? ( sys-libs/zlib )
+ socks5? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_configure() {
+ econf $(use_enable ssl) \
+ $(use_enable zlib) \
+ $(use_enable lzo) \
+ $(use_enable socks5 socks) \
+ --enable-shaper
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog Credits FAQ README README.Setup README.Shaper TODO
+ newinitd "${FILESDIR}"/vtun.rc vtun
+ insinto etc
+ doins "${FILESDIR}"/vtund-start.conf
+}
+
+pkg_postinst() {
+ elog "You will need the Universal TUN/TAP driver compiled into"
+ elog "your kernel or as a module to use the associated tunnel"
+ elog "modes in vtun."
+}