summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/squid/files')
-rw-r--r--net-proxy/squid/files/squid-3.0.14-adapted-zph.patch202
-rw-r--r--net-proxy/squid/files/squid-3.0.14-cross-compile.patch38
-rw-r--r--net-proxy/squid/files/squid-3.0.14-gcc43.patch39
-rw-r--r--net-proxy/squid/files/squid-3.0.14-gentoo.patch293
-rw-r--r--net-proxy/squid/files/squid-3.0.14-heimdal.patch18
-rw-r--r--net-proxy/squid/files/squid-3.0.14-max-forwards.patch12
6 files changed, 0 insertions, 602 deletions
diff --git a/net-proxy/squid/files/squid-3.0.14-adapted-zph.patch b/net-proxy/squid/files/squid-3.0.14-adapted-zph.patch
deleted file mode 100644
index 97b1b08c04f2..000000000000
--- a/net-proxy/squid/files/squid-3.0.14-adapted-zph.patch
+++ /dev/null
@@ -1,202 +0,0 @@
-diff -Nru squid-3.0.STABLE14.orig/src/cf.data.pre squid-3.0.STABLE14/src/cf.data.pre
---- squid-3.0.STABLE14.orig/src/cf.data.pre 2009-04-15 21:15:34.000000000 +0000
-+++ squid-3.0.STABLE14/src/cf.data.pre 2009-04-15 21:15:56.000000000 +0000
-@@ -1133,6 +1133,60 @@
- making the request.
- DOC_END
-
-+NAME: zph_tos_local
-+TYPE: int
-+DEFAULT: 0
-+LOC: Config.zph_tos_local
-+DOC_START
-+ Allows you to select a TOS/Diffserv value to mark local hits. Read above
-+ (tcp_outgoing_tos) for details/requirements about TOS.
-+ Default: 0 (disabled).
-+DOC_END
-+
-+NAME: zph_tos_peer
-+TYPE: int
-+DEFAULT: 0
-+LOC: Config.zph_tos_peer
-+DOC_START
-+ Allows you to select a TOS/Diffserv value to mark peer hits. Read above
-+ (tcp_outgoing_tos) for details/requirements about TOS.
-+ Default: 0 (disabled).
-+DOC_END
-+
-+NAME: zph_tos_parent
-+COMMENT: on|off
-+TYPE: onoff
-+LOC: Config.onoff.zph_tos_parent
-+DEFAULT: on
-+DOC_START
-+ Set this to off if you want only sibling hits to be marked.
-+ If set to on (default), parent hits are being marked too.
-+DOC_END
-+
-+NAME: zph_preserve_miss_tos
-+COMMENT: on|off
-+TYPE: onoff
-+LOC: Config.onoff.zph_preserve_miss_tos
-+DEFAULT: on
-+DOC_START
-+ If set to on (default), any HTTP response towards clients will
-+ have the TOS value of the response comming from the remote
-+ server masked with the value of zph_preserve_miss_tos_mask.
-+ For this to work correctly, you will need to patch your linux
-+ kernel with the TOS preserving ZPH patch.
-+DOC_END
-+
-+NAME: zph_preserve_miss_tos_mask
-+TYPE: int
-+DEFAULT: 255
-+LOC: Config.zph_preserve_miss_tos_mask
-+DOC_START
-+ Allows you to mask certain bits in the TOS received from the
-+ remote server, before copying the value to the TOS send towards
-+ clients.
-+ Default: 255 (TOS from server is not changed).
-+DOC_END
-+
- NAME: tcp_outgoing_address
- TYPE: acl_address
- DEFAULT: none
-diff -Nru squid-3.0.STABLE14.orig/src/client_side_reply.cc squid-3.0.STABLE14/src/client_side_reply.cc
---- squid-3.0.STABLE14.orig/src/client_side_reply.cc 2009-04-11 08:35:41.000000000 +0000
-+++ squid-3.0.STABLE14/src/client_side_reply.cc 2009-04-15 21:15:56.000000000 +0000
-@@ -48,6 +48,7 @@
- #include "ESI.h"
- #endif
- #include "MemObject.h"
-+#include "fde.h"
- #include "ACLChecklist.h"
- #include "ACL.h"
- #if DELAY_POOLS
-@@ -1550,6 +1551,11 @@
- /* guarantee nothing has been sent yet! */
- assert(http->out.size == 0);
- assert(http->out.offset == 0);
-+ if (Config.zph_tos_local)
-+ {
-+ debugs(33, 1, "ZPH hit hier.code=" << http->request->hier.code <<" TOS="<<Config.zph_tos_local);
-+ comm_set_tos(http->getConn()->fd,Config.zph_tos_local);
-+ }
- tempBuffer.offset = reqofs;
- tempBuffer.length = getNextNode()->readBuffer.length;
- tempBuffer.data = getNextNode()->readBuffer.data;
-@@ -1829,6 +1835,24 @@
- char *buf = next()->readBuffer.data;
-
- char *body_buf = buf;
-+
-+ if (reqofs==0 && !logTypeIsATcpHit(http->logType))
-+ {
-+ int tos = 0;
-+ if (Config.zph_tos_peer &&
-+ (http->request->hier.code==SIBLING_HIT ||
-+ (Config.onoff.zph_tos_parent && http->request->hier.code==PARENT_HIT)))
-+ {
-+ tos = Config.zph_tos_peer;
-+ debugs(33, 1, "ZPH: Peer hit, TOS="<<tos<<" hier.code="<<http->request->hier.code);
-+ }
-+ else if (Config.onoff.zph_preserve_miss_tos && Config.zph_preserve_miss_tos_mask)
-+ {
-+ tos = fd_table[fd].upstreamTOS & Config.zph_preserve_miss_tos_mask;
-+ debugs(33, 1, "ZPH: Preserving TOS on miss, TOS="<<tos);
-+ }
-+ comm_set_tos(fd,tos);
-+ }
-
- if (buf != result.data) {
- /* we've got to copy some data */
-diff -Nru squid-3.0.STABLE14.orig/src/fde.h squid-3.0.STABLE14/src/fde.h
---- squid-3.0.STABLE14.orig/src/fde.h 2009-04-11 08:35:41.000000000 +0000
-+++ squid-3.0.STABLE14/src/fde.h 2009-04-15 21:15:56.000000000 +0000
-@@ -106,7 +106,7 @@
- long handle;
- } win32;
- #endif
--
-+ unsigned char upstreamTOS; /* see FwdState::dispatch() */
- };
-
- #endif /* SQUID_FDE_H */
-diff -Nru squid-3.0.STABLE14.orig/src/forward.cc squid-3.0.STABLE14/src/forward.cc
---- squid-3.0.STABLE14.orig/src/forward.cc 2009-04-11 08:35:41.000000000 +0000
-+++ squid-3.0.STABLE14/src/forward.cc 2009-04-15 21:15:56.000000000 +0000
-@@ -965,6 +965,52 @@
-
- netdbPingSite(request->host);
-
-+ /* Retrieves remote server TOS value, and stores it as part of the
-+ * original client request FD object. It is later used to forward
-+ * remote server's TOS in the response to the client in case of a MISS.
-+ */
-+ fde * clientFde = &fd_table[client_fd];
-+ if (clientFde)
-+ {
-+ int tos = 1;
-+ int tos_len = sizeof(tos);
-+ clientFde->upstreamTOS = 0;
-+ if (setsockopt(server_fd,SOL_IP,IP_RECVTOS,&tos,tos_len)==0)
-+ {
-+ unsigned char buf[512];
-+ int len = 512;
-+ if (getsockopt(server_fd,SOL_IP,IP_PKTOPTIONS,buf,(socklen_t*)&len) == 0)
-+ {
-+ /* Parse the PKTOPTIONS structure to locate the TOS data message
-+ * prepared in the kernel by the ZPH incoming TCP TOS preserving
-+ * patch.
-+ */
-+ unsigned char * p = buf;
-+ while (p-buf < len)
-+ {
-+ struct cmsghdr *o = (struct cmsghdr*)p;
-+ if (o->cmsg_len<=0)
-+ break;
-+
-+ if (o->cmsg_level == SOL_IP && o->cmsg_type == IP_TOS)
-+ {
-+ clientFde->upstreamTOS = (unsigned char)(*(int*)CMSG_DATA(o));
-+ break;
-+ }
-+ p += CMSG_LEN(o->cmsg_len);
-+ }
-+ }
-+ else
-+ {
-+ debugs(33, 1, "ZPH: error in getsockopt(IP_PKTOPTIONS) on FD "<<server_fd<<" "<<xstrerror());
-+ }
-+ }
-+ else
-+ {
-+ debugs(33, 1, "ZPH: error in setsockopt(IP_RECVTOS) on FD "<<server_fd<<" "<<xstrerror());
-+ }
-+ }
-+
- if (servers && (p = servers->_peer)) {
- p->stats.fetches++;
- request->peer_login = p->login;
-diff -Nru squid-3.0.STABLE14.orig/src/structs.h squid-3.0.STABLE14/src/structs.h
---- squid-3.0.STABLE14.orig/src/structs.h 2009-04-11 08:35:42.000000000 +0000
-+++ squid-3.0.STABLE14/src/structs.h 2009-04-15 21:15:56.000000000 +0000
-@@ -553,6 +553,8 @@
- int emailErrData;
- int httpd_suppress_version_string;
- int global_internal_static;
-+ int zph_tos_parent;
-+ int zph_preserve_miss_tos;
- int debug_override_X;
- int WIN32_IpAddrChangeMonitor;
- }
-@@ -721,6 +723,9 @@
- int sleep_after_fork; /* microseconds */
- time_t minimum_expiry_time; /* seconds */
- external_acl *externalAclHelperList;
-+ int zph_tos_local;
-+ int zph_tos_peer;
-+ int zph_preserve_miss_tos_mask;
- #if USE_SSL
-
- struct
diff --git a/net-proxy/squid/files/squid-3.0.14-cross-compile.patch b/net-proxy/squid/files/squid-3.0.14-cross-compile.patch
deleted file mode 100644
index 77d96c7d23ee..000000000000
--- a/net-proxy/squid/files/squid-3.0.14-cross-compile.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -Nru squid-3.0.STABLE14.orig/configure.in squid-3.0.STABLE14/configure.in
---- squid-3.0.STABLE14.orig/configure.in 2009-04-25 11:24:10.000000000 +0000
-+++ squid-3.0.STABLE14/configure.in 2009-04-25 11:31:02.000000000 +0000
-@@ -1820,6 +1820,10 @@
- ;;
- esac
-
-+dnl Define HOSTCXX
-+HOSTCXX="$build-g++"
-+AC_SUBST(HOSTCXX)
-+
- dnl Check for programs
- AC_PROG_CPP
- AC_PROG_INSTALL
-diff -Nru squid-3.0.STABLE14.orig/src/Makefile.am squid-3.0.STABLE14/src/Makefile.am
---- squid-3.0.STABLE14.orig/src/Makefile.am 2009-04-25 11:24:10.000000000 +0000
-+++ squid-3.0.STABLE14/src/Makefile.am 2009-04-25 11:31:02.000000000 +0000
-@@ -1007,6 +1007,8 @@
-
- DEFS = @DEFS@ -DDEFAULT_CONFIG_FILE=\"$(DEFAULT_CONFIG_FILE)\"
-
-+HOSTCXX ?= @HOSTCXX@
-+
- $(OBJS): $(top_srcdir)/include/version.h ../include/autoconf.h
-
- snmp_core.o snmp_agent.o: ../snmplib/libsnmp.a $(top_srcdir)/include/cache_snmp.h
-@@ -1030,6 +1032,11 @@
- squid.conf.default: cf_parser.h
- true
-
-+cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES)
-+ $(HOSTCXX) -o $@ $(srcdir)/cf_gen.cc \
-+ $(top_srcdir)/lib/util.c $(top_srcdir)/lib/assert.c \
-+ -DNDEBUG -DBUILD_HOST_TOOL ${INCLUDES}
-+
- cf_parser.h: cf.data cf_gen$(EXEEXT)
- ./cf_gen cf.data $(srcdir)/cf.data.depend
-
diff --git a/net-proxy/squid/files/squid-3.0.14-gcc43.patch b/net-proxy/squid/files/squid-3.0.14-gcc43.patch
deleted file mode 100644
index cc2a843201c5..000000000000
--- a/net-proxy/squid/files/squid-3.0.14-gcc43.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -Nru squid-3.0.STABLE14.orig/lib/util.c squid-3.0.STABLE14/lib/util.c
---- squid-3.0.STABLE14.orig/lib/util.c 2009-04-11 08:35:38.000000000 +0000
-+++ squid-3.0.STABLE14/lib/util.c 2009-04-25 11:28:40.000000000 +0000
-@@ -755,7 +755,7 @@
-
- PROF_stop(xstrdup);
-
-- return p;
-+ return (char *)p;
- }
-
- /*
-@@ -765,7 +765,7 @@
- xstrndup(const char *s, size_t n)
- {
- size_t sz;
-- void *p;
-+ char *p;
- PROF_start(xstrndup);
- assert(s != NULL);
- assert(n);
-@@ -774,7 +774,7 @@
- if (sz > n)
- sz = n;
-
-- p = xstrncpy(xmalloc(sz), s, sz);
-+ p = xstrncpy((char *)xmalloc(sz), s, sz);
-
- PROF_stop(xstrndup);
-
-@@ -923,7 +923,7 @@
- xint64toa(int64_t num)
- {
- static char buf[24]; /* 2^64 = 18446744073709551616 */
-- snprintf(buf, sizeof(buf), "%" PRId64, num);
-+ snprintf(buf, sizeof(buf), "%" PRId64, (long long int)num);
- return buf;
- }
-
diff --git a/net-proxy/squid/files/squid-3.0.14-gentoo.patch b/net-proxy/squid/files/squid-3.0.14-gentoo.patch
deleted file mode 100644
index 1e25ec9838a0..000000000000
--- a/net-proxy/squid/files/squid-3.0.14-gentoo.patch
+++ /dev/null
@@ -1,293 +0,0 @@
-diff -Nru squid-3.0.STABLE14.orig/acinclude.m4 squid-3.0.STABLE14/acinclude.m4
---- squid-3.0.STABLE14.orig/acinclude.m4 2009-04-11 08:35:27.000000000 +0000
-+++ squid-3.0.STABLE14/acinclude.m4 2009-04-15 21:14:50.000000000 +0000
-@@ -73,7 +73,7 @@
- AC_MSG_CHECKING([whether compiler accepts -fhuge-objects])
- AC_CACHE_VAL([ac_cv_test_checkforhugeobjects],[
- ac_cv_test_checkforhugeobjects=`echo "int foo;" > conftest.cc
--${CXX} -Werror -fhuge-objects -c conftest.cc 2>/dev/null
-+${CXX} -fhuge-objects -c conftest.cc 2>/dev/null
- res=$?
- rm -f conftest.*
- echo yes
-diff -Nru squid-3.0.STABLE14.orig/configure.in squid-3.0.STABLE14/configure.in
---- squid-3.0.STABLE14.orig/configure.in 2009-04-11 08:35:42.000000000 +0000
-+++ squid-3.0.STABLE14/configure.in 2009-04-15 21:14:50.000000000 +0000
-@@ -15,9 +15,9 @@
- PRESET_LDFLAGS="$LDFLAGS"
-
- dnl Set default LDFLAGS
--if test -z "$LDFLAGS"; then
-- LDFLAGS="-g"
--fi
-+dnl if test -z "$LDFLAGS"; then
-+dnl LDFLAGS="-g"
-+dnl fi
-
- dnl Check for GNU cc
- AC_PROG_CC
-@@ -177,13 +177,13 @@
- dnl TODO: check if the problem will be present in any other newer MinGW release.
- case "$host_os" in
- mingw|mingw32)
-- SQUID_CFLAGS="-Werror -Wall -Wpointer-arith -Wwrite-strings -Wcomments"
-+ SQUID_CFLAGS="-Wall -Wpointer-arith -Wwrite-strings"
- ;;
- *)
-- SQUID_CFLAGS="-Werror -Wall -Wpointer-arith -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wcomments"
-+ SQUID_CFLAGS="-Wall -Wpointer-arith -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations"
- ;;
- esac
-- SQUID_CXXFLAGS="-Werror -Wall -Wpointer-arith -Wwrite-strings -Wcomments"
-+ SQUID_CXXFLAGS="-Wall -Wpointer-arith -Wwrite-strings"
- else
- SQUID_CFLAGS=
- SQUID_CXXFLAGS=
-diff -Nru squid-3.0.STABLE14.orig/helpers/basic_auth/MSNT/confload.c squid-3.0.STABLE14/helpers/basic_auth/MSNT/confload.c
---- squid-3.0.STABLE14.orig/helpers/basic_auth/MSNT/confload.c 2009-04-11 08:35:32.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/basic_auth/MSNT/confload.c 2009-04-15 21:14:50.000000000 +0000
-@@ -27,7 +27,7 @@
-
- /* Path to configuration file */
- #ifndef SYSCONFDIR
--#define SYSCONFDIR "/usr/local/squid/etc"
-+#define SYSCONFDIR "/etc/squid"
- #endif
- #define CONFIGFILE SYSCONFDIR "/msntauth.conf"
-
-diff -Nru squid-3.0.STABLE14.orig/helpers/basic_auth/MSNT/msntauth.conf.default squid-3.0.STABLE14/helpers/basic_auth/MSNT/msntauth.conf.default
---- squid-3.0.STABLE14.orig/helpers/basic_auth/MSNT/msntauth.conf.default 2009-04-11 08:35:33.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/basic_auth/MSNT/msntauth.conf.default 2009-04-15 21:14:50.000000000 +0000
-@@ -8,6 +8,6 @@
- server other_PDC other_BDC otherdomain
-
- # Denied and allowed users. Comment these if not needed.
--#denyusers /usr/local/squid/etc/msntauth.denyusers
--#allowusers /usr/local/squid/etc/msntauth.allowusers
-+#denyusers /etc/squid/msntauth.denyusers
-+#allowusers /etc/squid/msntauth.allowusers
-
-diff -Nru squid-3.0.STABLE14.orig/helpers/basic_auth/SMB/Makefile.am squid-3.0.STABLE14/helpers/basic_auth/SMB/Makefile.am
---- squid-3.0.STABLE14.orig/helpers/basic_auth/SMB/Makefile.am 2009-04-11 08:35:33.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/basic_auth/SMB/Makefile.am 2009-04-15 21:14:50.000000000 +0000
-@@ -14,7 +14,7 @@
- ## FIXME: autoconf should test for the samba path.
-
- SMB_AUTH_HELPER = smb_auth.sh
--SAMBAPREFIX=/usr/local/samba
-+SAMBAPREFIX=/usr
- SMB_AUTH_HELPER_PATH = $(libexecdir)/$(SMB_AUTH_HELPER)
-
- libexec_SCRIPTS = $(SMB_AUTH_HELPER)
-diff -Nru squid-3.0.STABLE14.orig/helpers/basic_auth/SMB/smb_auth.sh squid-3.0.STABLE14/helpers/basic_auth/SMB/smb_auth.sh
---- squid-3.0.STABLE14.orig/helpers/basic_auth/SMB/smb_auth.sh 2009-04-11 08:35:33.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/basic_auth/SMB/smb_auth.sh 2009-04-15 21:14:50.000000000 +0000
-@@ -24,7 +24,7 @@
- read AUTHSHARE
- read AUTHFILE
- read SMBUSER
--read SMBPASS
-+read -r SMBPASS
-
- # Find domain controller
- echo "Domain name: $DOMAINNAME"
-@@ -47,7 +47,7 @@
- addropt=""
- fi
- echo "Query address options: $addropt"
--dcip=`$SAMBAPREFIX/bin/nmblookup $addropt "$PASSTHROUGH#1c" | awk '/^[0-9.]+ / { print $1 ; exit }'`
-+dcip=`$SAMBAPREFIX/bin/nmblookup $addropt "$PASSTHROUGH#1c" | awk '/^[0-9.]+\..+ / { print $1 ; exit }'`
- echo "Domain controller IP address: $dcip"
- [ -n "$dcip" ] || exit 1
-
-diff -Nru squid-3.0.STABLE14.orig/helpers/external_acl/session/squid_session.8 squid-3.0.STABLE14/helpers/external_acl/session/squid_session.8
---- squid-3.0.STABLE14.orig/helpers/external_acl/session/squid_session.8 2009-04-11 08:35:34.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/external_acl/session/squid_session.8 2009-04-15 21:14:50.000000000 +0000
-@@ -35,7 +35,7 @@
- .P
- Configuration example using the default automatic mode
- .IP
--external_acl_type session ttl=300 negative_ttl=0 children=1 concurrency=200 %LOGIN /usr/local/squid/libexec/squid_session
-+external_acl_type session ttl=300 negative_ttl=0 children=1 concurrency=200 %LOGIN /usr/libexec/squid/squid_session
- .IP
- acl session external session
- .IP
-diff -Nru squid-3.0.STABLE14.orig/helpers/external_acl/unix_group/squid_unix_group.8 squid-3.0.STABLE14/helpers/external_acl/unix_group/squid_unix_group.8
---- squid-3.0.STABLE14.orig/helpers/external_acl/unix_group/squid_unix_group.8 2009-04-11 08:35:34.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/external_acl/unix_group/squid_unix_group.8 2009-04-15 21:14:50.000000000 +0000
-@@ -27,7 +27,7 @@
- This squid.conf example defines two Squid acls. usergroup1 matches users in group1, and usergroup2
- matches users in group2 or group3
- .IP
--external_acl_type unix_group %LOGIN /usr/local/squid/libexec/squid_unix_group -p
-+external_acl_type unix_group %LOGIN /usr/libexec/squid/squid_unix_group -p
- .IP
- acl usergroup1 external unix_group group1
- .IP
-diff -Nru squid-3.0.STABLE14.orig/helpers/negotiate_auth/squid_kerb_auth/do.sh squid-3.0.STABLE14/helpers/negotiate_auth/squid_kerb_auth/do.sh
---- squid-3.0.STABLE14.orig/helpers/negotiate_auth/squid_kerb_auth/do.sh 2009-04-11 08:35:34.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/negotiate_auth/squid_kerb_auth/do.sh 2009-04-15 21:14:50.000000000 +0000
-@@ -7,7 +7,7 @@
- #
- CC=gcc
- #CFLAGS="-Wall -Wextra -Werror -Wcomment -Wpointer-arith -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wdeclaration-after-statement -Wshadow -O2"
--CFLAGS="-Wall -Werror -Wcomment -Wpointer-arith -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wshadow -O2"
-+CFLAGS="-Wall -Wpointer-arith -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wshadow -O2"
- if [ "$1" = "HEIMDAL" ]; then
- DEFINE="-DHEIMDAL -D__LITTLE_ENDIAN__"
- INCLUDE="-I/usr/include/heimdal -Ispnegohelp"
-diff -Nru squid-3.0.STABLE14.orig/lib/libTrie/acinclude.m4 squid-3.0.STABLE14/lib/libTrie/acinclude.m4
---- squid-3.0.STABLE14.orig/lib/libTrie/acinclude.m4 2009-04-11 08:35:38.000000000 +0000
-+++ squid-3.0.STABLE14/lib/libTrie/acinclude.m4 2009-04-15 21:14:50.000000000 +0000
-@@ -9,7 +9,7 @@
- AC_MSG_CHECKING([whether compiler accepts -fhuge-objects])
- AC_CACHE_VAL([ac_cv_test_checkforhugeobjects],[
- ac_cv_test_checkforhugeobjects=`echo "int foo;" > conftest.cc
--${CXX} -Werror -fhuge-objects -c conftest.cc 2>/dev/null
-+${CXX} -fhuge-objects -c conftest.cc 2>/dev/null
- res=$?
- rm -f conftest.*
- echo yes
-diff -Nru squid-3.0.STABLE14.orig/lib/libTrie/configure.in squid-3.0.STABLE14/lib/libTrie/configure.in
---- squid-3.0.STABLE14.orig/lib/libTrie/configure.in 2009-04-11 08:35:38.000000000 +0000
-+++ squid-3.0.STABLE14/lib/libTrie/configure.in 2009-04-15 21:14:50.000000000 +0000
-@@ -58,8 +58,8 @@
-
- dnl set useful flags
- if test "$GCC" = "yes"; then
-- TRIE_CFLAGS="-Werror -Wall -Wpointer-arith -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wcomments"
-- TRIE_CXXFLAGS="-Werror -Wall -Wpointer-arith -Wwrite-strings -Wcomments"
-+ TRIE_CFLAGS="-Wall -Wpointer-arith -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations"
-+ TRIE_CXXFLAGS="-Wall -Wpointer-arith -Wwrite-strings"
- else
- TRIE_CFLAGS=
- TRIE_CXXFLAGS=
-diff -Nru squid-3.0.STABLE14.orig/src/cf.data.pre squid-3.0.STABLE14/src/cf.data.pre
---- squid-3.0.STABLE14.orig/src/cf.data.pre 2009-04-11 08:35:40.000000000 +0000
-+++ squid-3.0.STABLE14/src/cf.data.pre 2009-04-15 21:14:50.000000000 +0000
-@@ -652,6 +652,8 @@
- acl Safe_ports port 488 # gss-http
- acl Safe_ports port 591 # filemaker
- acl Safe_ports port 777 # multiling http
-+acl Safe_ports port 901 # SWAT
-+acl purge method PURGE
- acl CONNECT method CONNECT
- NOCOMMENT_END
- DOC_END
-@@ -685,6 +687,9 @@
- # Only allow cachemgr access from localhost
- http_access allow manager localhost
- http_access deny manager
-+# Only allow purge requests from localhost
-+http_access allow purge localhost
-+http_access deny purge
- # Deny requests to unknown ports
- http_access deny !Safe_ports
- # Deny CONNECT to other than SSL ports
-@@ -702,6 +707,9 @@
- # from where browsing should be allowed
- http_access allow localnet
-
-+# Allow the localhost to have access by default
-+http_access allow localhost
-+
- # And finally deny all other access to this proxy
- http_access deny all
- NOCOMMENT_END
-@@ -3264,11 +3272,11 @@
-
- NAME: cache_mgr
- TYPE: string
--DEFAULT: webmaster
-+DEFAULT: root
- LOC: Config.adminEmail
- DOC_START
- Email-address of local cache manager who will receive
-- mail if the cache dies. The default is "webmaster."
-+ mail if the cache dies. The default is "root".
- DOC_END
-
- NAME: mail_from
-@@ -5218,6 +5226,9 @@
- If you disable this, it will appear as
-
- X-Forwarded-For: unknown
-+NOCOMMENT_START
-+forwarded_for off
-+NOCOMMENT_END
- DOC_END
-
- NAME: cachemgr_passwd
-diff -Nru squid-3.0.STABLE14.orig/src/debug.cc squid-3.0.STABLE14/src/debug.cc
---- squid-3.0.STABLE14.orig/src/debug.cc 2009-04-11 08:35:41.000000000 +0000
-+++ squid-3.0.STABLE14/src/debug.cc 2009-04-15 21:14:50.000000000 +0000
-@@ -465,7 +465,7 @@
- #if HAVE_SYSLOG && defined(LOG_LOCAL4)
-
- if (opt_syslog_enable)
-- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, syslog_facility);
-+ openlog(appname, LOG_PID | LOG_NDELAY, syslog_facility);
-
- #endif /* HAVE_SYSLOG */
-
-diff -Nru squid-3.0.STABLE14.orig/src/defines.h squid-3.0.STABLE14/src/defines.h
---- squid-3.0.STABLE14.orig/src/defines.h 2009-04-11 08:35:41.000000000 +0000
-+++ squid-3.0.STABLE14/src/defines.h 2009-04-15 21:14:50.000000000 +0000
-@@ -218,7 +218,7 @@
-
- /* were to look for errors if config path fails */
- #ifndef DEFAULT_SQUID_ERROR_DIR
--#define DEFAULT_SQUID_ERROR_DIR "/usr/local/squid/etc/errors"
-+#define DEFAULT_SQUID_ERROR_DIR "/usr/share/squid/errors/English"
- #endif
-
- /* handy to determine the #elements in a static array */
-diff -Nru squid-3.0.STABLE14.orig/src/main.cc squid-3.0.STABLE14/src/main.cc
---- squid-3.0.STABLE14.orig/src/main.cc 2009-04-11 08:35:41.000000000 +0000
-+++ squid-3.0.STABLE14/src/main.cc 2009-04-15 21:14:50.000000000 +0000
-@@ -1490,7 +1490,7 @@
- if (*(argv[0]) == '(')
- return;
-
-- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
-+ openlog(appname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
-
- if ((pid = fork()) < 0)
- syslog(LOG_ALERT, "fork failed: %s", xstrerror());
-@@ -1534,7 +1534,7 @@
-
- if ((pid = fork()) == 0) {
- /* child */
-- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
-+ openlog(appname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
- prog = xstrdup(argv[0]);
- argv[0] = xstrdup("(squid)");
- execvp(prog, argv);
-@@ -1542,7 +1542,7 @@
- }
-
- /* parent */
-- openlog(appname, LOG_PID | LOG_NDELAY | LOG_CONS, LOG_LOCAL4);
-+ openlog(appname, LOG_PID | LOG_NDELAY, LOG_DAEMON);
-
- syslog(LOG_NOTICE, "Squid Parent: child process %d started", pid);
-
-diff -Nru squid-3.0.STABLE14.orig/src/Makefile.am squid-3.0.STABLE14/src/Makefile.am
---- squid-3.0.STABLE14.orig/src/Makefile.am 2009-04-11 08:35:40.000000000 +0000
-+++ squid-3.0.STABLE14/src/Makefile.am 2009-04-15 21:14:50.000000000 +0000
-@@ -991,12 +991,12 @@
- DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
- DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
- DEFAULT_DNSSERVER = $(libexecdir)/`echo dnsserver | sed '$(transform);s/$$/$(EXEEXT)/'`
--DEFAULT_LOG_PREFIX = $(localstatedir)/logs
-+DEFAULT_LOG_PREFIX = $(localstatedir)/log/squid
- DEFAULT_CACHE_LOG = $(DEFAULT_LOG_PREFIX)/cache.log
- DEFAULT_ACCESS_LOG = $(DEFAULT_LOG_PREFIX)/access.log
- DEFAULT_STORE_LOG = $(DEFAULT_LOG_PREFIX)/store.log
--DEFAULT_PID_FILE = $(DEFAULT_LOG_PREFIX)/squid.pid
--DEFAULT_SWAP_DIR = $(localstatedir)/cache
-+DEFAULT_PID_FILE = $(localstatedir)/run/squid.pid
-+DEFAULT_SWAP_DIR = $(localstatedir)/cache/squid
- DEFAULT_PINGER = $(libexecdir)/`echo pinger | sed '$(transform);s/$$/$(EXEEXT)/'`
- DEFAULT_UNLINKD = $(libexecdir)/`echo unlinkd | sed '$(transform);s/$$/$(EXEEXT)/'`
- DEFAULT_DISKD = $(libexecdir)/`echo diskd | sed '$(transform);s/$$/$(EXEEXT)/'`
diff --git a/net-proxy/squid/files/squid-3.0.14-heimdal.patch b/net-proxy/squid/files/squid-3.0.14-heimdal.patch
deleted file mode 100644
index ec1e37bf7acc..000000000000
--- a/net-proxy/squid/files/squid-3.0.14-heimdal.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Nru squid-3.0.STABLE14.orig/helpers/negotiate_auth/squid_kerb_auth/Makefile.am squid-3.0.STABLE14/helpers/negotiate_auth/squid_kerb_auth/Makefile.am
---- squid-3.0.STABLE14.orig/helpers/negotiate_auth/squid_kerb_auth/Makefile.am 2009-04-11 08:35:34.000000000 +0000
-+++ squid-3.0.STABLE14/helpers/negotiate_auth/squid_kerb_auth/Makefile.am 2009-04-15 21:17:01.000000000 +0000
-@@ -18,10 +18,10 @@
- #-L$(top_builddir)/lib -lmiscutil $(XTRA_LIBS)
-
- # HEIMDAL
--#KERBINC = -DHEIMDAL -I/usr/include/heimdal
--#KERBLIBS = -lgssapi -lkrb5 -lcom_err -lasn1 -lroken
-+KERBINC = -DHEIMDAL -I/usr/include/heimdal
-+KERBLIBS = -lgssapi -lkrb5 -lcom_err -lasn1 -lroken
-
- # MIT
--KERBINC =
--KERBLIBS = -lgssapi_krb5 -lkrb5 -lcom_err
-+#KERBINC =
-+#KERBLIBS = -lgssapi_krb5 -lkrb5 -lcom_err
-
diff --git a/net-proxy/squid/files/squid-3.0.14-max-forwards.patch b/net-proxy/squid/files/squid-3.0.14-max-forwards.patch
deleted file mode 100644
index 52b274f81b29..000000000000
--- a/net-proxy/squid/files/squid-3.0.14-max-forwards.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nru squid-3.0.STABLE14.orig/src/HttpHeader.cc squid-3.0.STABLE14/src/HttpHeader.cc
---- squid-3.0.STABLE14.orig/src/HttpHeader.cc 2009-04-11 08:35:40.000000000 +0000
-+++ squid-3.0.STABLE14/src/HttpHeader.cc 2009-04-25 11:34:00.000000000 +0000
-@@ -106,7 +106,7 @@
- {"Last-Modified", HDR_LAST_MODIFIED, ftDate_1123},
- {"Link", HDR_LINK, ftStr},
- {"Location", HDR_LOCATION, ftStr},
-- {"Max-Forwards", HDR_MAX_FORWARDS, ftInt},
-+ {"Max-Forwards", HDR_MAX_FORWARDS, ftInt64},
- {"Mime-Version", HDR_MIME_VERSION, ftStr}, /* for now */
- {"Pragma", HDR_PRAGMA, ftStr},
- {"Proxy-Authenticate", HDR_PROXY_AUTHENTICATE, ftStr},