summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/chillispot/chillispot-1.0.ebuild')
-rw-r--r--net-wireless/chillispot/chillispot-1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-wireless/chillispot/chillispot-1.0.ebuild b/net-wireless/chillispot/chillispot-1.0.ebuild
new file mode 100644
index 000000000000..112137ef40c0
--- /dev/null
+++ b/net-wireless/chillispot/chillispot-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/chillispot/chillispot-1.0.ebuild,v 1.1 2005/10/20 16:51:11 solar Exp $
+
+inherit eutils flag-o-matic gnuconfig
+
+DESCRIPTION="ChilliSpot is an open source captive portal or wireless LAN access point controller."
+HOMEPAGE="http://www.chillispot.org"
+SRC_URI="http://www.chillispot.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc >=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+ chmod 644 doc/*.conf
+ find . -exec chmod go-w '{}' \;
+}
+
+src_compile() {
+ export CFLAGS
+ econf || die "FAILED: econf"
+ emake || die "FAILED: emake"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ cd doc && dodoc chilli.conf freeradius.users hotspotlogin.cgi firewall.iptables
+}