summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/galeon/galeon-1.3.5-r1.ebuild')
-rw-r--r--net-www/galeon/galeon-1.3.5-r1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/net-www/galeon/galeon-1.3.5-r1.ebuild b/net-www/galeon/galeon-1.3.5-r1.ebuild
index ca3123dcc69b..c531fb8cd7b1 100644
--- a/net-www/galeon/galeon-1.3.5-r1.ebuild
+++ b/net-www/galeon/galeon-1.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.3.5-r1.ebuild,v 1.1 2003/07/11 19:31:00 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.3.5-r1.ebuild,v 1.2 2003/07/12 18:16:32 liquidx Exp $
inherit gnome2 libtool
@@ -14,11 +14,9 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
SLOT="0"
-REQ_MOZ_VER="1.4"
-
-# we only allow this to build against moz-1.3, on purpose.
+# supports both moz-1.3 and moz-1.4
RDEPEND="virtual/x11
- =net-www/mozilla-1.4*
+ >=net-www/mozilla-1.3
>=dev-libs/glib-2.0
>=x11-libs/gtk+-2.0
>=dev-libs/libxml2-2.4
@@ -50,9 +48,6 @@ src_compile() {
local moz_ver="`pkg-config --modversion mozilla-xpcom | cut -d. -f1,2 2>/dev/null`"
local myconf="--disable-werror"
- if [ -z "${moz_ver}" ]; then
- moz_ver=${REQ_MOZ_VER}
- fi
myconf="${myconf} --with-mozilla-snapshot=${moz_ver}"
econf ${myconf} || die "configure failed"