summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mozilla-launcher/mozilla-launcher-1.20.ebuild')
-rw-r--r--net-www/mozilla-launcher/mozilla-launcher-1.20.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-www/mozilla-launcher/mozilla-launcher-1.20.ebuild b/net-www/mozilla-launcher/mozilla-launcher-1.20.ebuild
new file mode 100644
index 000000000000..e76f7df4b168
--- /dev/null
+++ b/net-www/mozilla-launcher/mozilla-launcher-1.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-launcher/mozilla-launcher-1.20.ebuild,v 1.1 2004/09/28 01:35:15 agriffis Exp $
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE=""
+SRC_URI="mirror://gentoo/${P}.bz2
+ http://dev.gentoo.org/~agriffis/${PN}/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~mips ~ppc64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher
+}
+
+pkg_postinst() {
+ local f
+
+ find ${ROOT}/usr/bin -type l -maxdepth 1 | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}