summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild')
-rw-r--r--sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild b/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
index fbca1431dc3e..c86fddd7b9cf 100644
--- a/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
+++ b/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild,v 1.6 2012/02/03 11:52:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/msms-bin/msms-bin-2.6.1-r1.ebuild,v 1.7 2012/05/23 07:56:19 jlec Exp $
-EAPI=3
+EAPI=4
DESCRIPTION="MSMS allows to compute very efficiently triangulations of Solvent Excluded Surfaces"
HOMEPAGE="http://mgl.scripps.edu/people/sanner/html/msms_home.html"
@@ -20,26 +20,26 @@ RESTRICT="fetch"
S="${WORKDIR}"
-QA_DT_HASH="${EROOT#/}opt/bin/.*"
+QA_PREBUILT="${EROOT#/}opt/bin/.*"
pkg_nofetch() {
einfo "Please download ${A} from http://mgltools.scripps.edu/downloads#msms and place it to ${DISTDIR}"
}
src_install() {
- doman msms.1 || die
- dodoc README msms.html ReleaseNotes || die
+ doman msms.1
+ dodoc README msms.html ReleaseNotes
exeinto /opt/bin
if use amd64; then
- newexe ${PN%-bin}.x86_64Linux2.${PV} msms || die
+ newexe ${PN%-bin}.x86_64Linux2.${PV} msms
elif use x86; then
- newexe ${PN%-bin}.i86Linux2.${PV} msms || die
+ newexe ${PN%-bin}.i86Linux2.${PV} msms
fi
insinto /usr/share/${PN}/
- doins atmtypenumbers || die
+ doins atmtypenumbers
sed \
-e 's:nawk:awk:g' \
-e "s:./atmtypenumbers:${EPREFIX}/usr/share/${PN}/atmtypenumbers:g" \
-i pdb_to_xyz* || die
- dobin pdb_to_xyz* || die
+ dobin pdb_to_xyz*
}