summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/naga/naga-2.1.ebuild')
-rw-r--r--sci-libs/naga/naga-2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/naga/naga-2.1.ebuild b/sci-libs/naga/naga-2.1.ebuild
new file mode 100644
index 000000000000..4f85bb58be25
--- /dev/null
+++ b/sci-libs/naga/naga-2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/naga/naga-2.1.ebuild,v 1.1 2012/05/31 20:50:17 je_fro Exp $
+EAPI=4
+
+inherit subversion java-pkg-2 java-ant-2
+
+ESVN_REPO_URI="http://naga.googlecode.com/svn/trunk@57"
+MY_PV=${PV//./_}
+MY_PVR="${MY_PV}-r43"
+
+DESCRIPTION="Simplified Java NIO asynchronous sockets"
+HOMEPAGE="http://code.google.com/p/naga/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.5"
+
+src_compile() {
+ eant build
+}
+
+src_install() {
+ java-pkg_newjar _DIST/${PN}-${MY_PVR}.jar ${PN}.jar
+}