summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/9base/9base-6-r1.ebuild')
-rw-r--r--sys-apps/9base/9base-6-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sys-apps/9base/9base-6-r1.ebuild b/sys-apps/9base/9base-6-r1.ebuild
index 4054a2a3100a..92eb1477cacc 100644
--- a/sys-apps/9base/9base-6-r1.ebuild
+++ b/sys-apps/9base/9base-6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/9base/9base-6-r1.ebuild,v 1.1 2010/06/19 14:41:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/9base/9base-6-r1.ebuild,v 1.2 2011/04/15 18:15:55 ssuominen Exp $
-EAPI=2
+EAPI=4
inherit toolchain-funcs
DESCRIPTION="A port of various original Plan 9 tools for Unix, based on plan9port"
@@ -17,8 +17,6 @@ IUSE=""
MAKEOPTS="${MAKEOPTS} -j1"
pkg_setup() {
- export PORTAGE_COMPRESS=
-
local _objtype=386
[[ $(tc-arch) == "amd64" ]] && _objtype=x86_64
@@ -45,4 +43,7 @@ src_compile() {
src_install() {
emake "${my9baseopts[@]}" install || die
dodoc README
+
+ # We don't compress to keep support for plan9's man
+ docompress -x /usr/plan9/share/man
}