summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ifplugd/ifplugd-0.28.ebuild')
-rw-r--r--sys-apps/ifplugd/ifplugd-0.28.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/sys-apps/ifplugd/ifplugd-0.28.ebuild b/sys-apps/ifplugd/ifplugd-0.28.ebuild
deleted file mode 100644
index f33f13795ff3..000000000000
--- a/sys-apps/ifplugd/ifplugd-0.28.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifplugd/ifplugd-0.28.ebuild,v 1.3 2005/09/01 15:33:28 uberlord Exp $
-
-inherit eutils
-
-DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
-HOMEPAGE="http://0pointer.de/lennart/projects/ifplugd/"
-SRC_URI="http://0pointer.de/lennart/projects/ifplugd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc"
-
-DEPEND="dev-util/pkgconfig
- doc? ( www-client/lynx )"
-RDEPEND=">=dev-libs/libdaemon-0.5"
-
-# Gentoo-provided scripts. Version is for the scripts, not ifplugd.
-INITSCRIPT=${FILESDIR}/gentoo-ifplugd-init-v3
-ACTIONSCRIPT=${FILESDIR}/gentoo-ifplugd.action-v2
-CONFFILE=${FILESDIR}/gentoo-ifplugd-conf-v3
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
-}
-
-src_compile() {
- econf $(use_enable doc lynx) \
- --with-initdir=/etc/init.d \
- --disable-xmltoman \
- --disable-subversion \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- newsbin ${ACTIONSCRIPT} ifplugd.action
-
- # Fix init.d configuration
- rm -fr ${D}/etc/ifplugd ${D}/etc/init.d/ifplugd
-
- insinto /etc/conf.d ; newins ${CONFFILE} ${PN} || die
- exeinto /etc/init.d ; newexe ${INITSCRIPT} ${PN} || die
-
- cd ${S}/doc
- dodoc README SUPPORTED_DRIVERS
- use doc && dohtml *.{html,css}
-}