summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.11g-r1.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.11g-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/sys-apps/util-linux/util-linux-2.11g-r1.ebuild b/sys-apps/util-linux/util-linux-2.11g-r1.ebuild
deleted file mode 100644
index 153c98f7f606..000000000000
--- a/sys-apps/util-linux/util-linux-2.11g-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11g-r1.ebuild,v 1.1 2001/08/04 18:22:45 pete Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Various useful Linux utilities"
-SRC_URI="ftp://ftp.win.tue.nl/pub/linux-local/utils/util-linux/${P}.tar.gz"
-
-DEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
-
-RDEPEND="$DEPEND
- sys-devel/perl"
-
-src_unpack() {
-
- unpack ${P}.tar.gz
- cd ${S}
- cp MCONFIG MCONFIG.orig
- sed -e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
- -e "s:CPU=.*:CPU=${CHOST%%-*}:" \
- -e "s:HAVE_PAM=no:HAVE_PAM=yes:" \
- -e "s:HAVE_SLN=no:HAVE_SLN=yes:" \
- -e "s:HAVE_TSORT=no:HAVE_TSORT=yes:" \
- -e "s:usr/man:usr/share/man:" \
- -e "s:usr/info:usr/share/info:" \
- MCONFIG.orig > MCONFIG.orig2
- if [ "`use simpleinit`" ]
- then
- sed -e "s:HAVE_SYSVINIT=yes:HAVE_SYSVINIT=no:" \
- -e "s:HAVE_SYSVINIT_UTILS=yes:HAVE_SYSVINIT_UTILS=no:" \
- MCONFIG.orig2 > MCONFIG
- else
- mv MCONFIG.orig2 MCONFIG
- fi
-
-}
-
-src_compile() {
-
- try ./configure
- try make ${MAKEOPTS} LDFLAGS=""
-}
-
-
-src_install() {
-
- try make DESTDIR=${D} install
-
- if [ -z "`use bootcd`" ]
- then
- dodoc HISTORY MAINTAINER README VERSION
- docinto licenses
- dodoc licenses/* HISTORY
- docinto examples
- dodoc example.files/*
- else
- rm -rf ${D}/usr/games
- rm -rf ${D}/usr/share/{doc,man,info,misc/getopt,locale}
- fi
-}
-
-