summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xmbmon/xmbmon-2.0.3.ebuild')
-rw-r--r--sys-apps/xmbmon/xmbmon-2.0.3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
deleted file mode 100644
index 0c2ae5e1ddfd..000000000000
--- a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.3.ebuild,v 1.10 2006/03/08 01:53:30 vapier Exp $
-
-inherit eutils
-
-MY_P="${PN}${PV//.}"
-DESCRIPTION="Mother Board Monitor Program for X Window System"
-HOMEPAGE="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
-SRC_URI="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/${MY_P}.tar.gz"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="x86 amd64"
-IUSE="X"
-
-DEPEND="X? ( || ( ( x11-libs/libXt x11-libs/libSM x11-libs/libX11 x11-libs/libICE ) virtual/x11 ) )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/xmbmon-2.0.3-gcc34.patch
-}
-
-src_compile() {
- econf || die "Configure failed"
- emake DEFS="$DEFS -DLINUX" CFLAGS="$CFLAGS \$(INCLUDES) \$(DEFS)" mbmon || die "Make mbmon failed"
- if use X ; then
- emake DEFS="$DEFS -DLINUX" CFLAGSX="$CFLAGS \$(INCLUDES) \$(DEFS)" xmbmon || die "Make xmbmon failed"
- fi
-}
-
-src_install() {
- dosbin mbmon
- fperms 4555 /usr/sbin/mbmon
- fowners root:wheel /usr/sbin/mbmon
-
- if use X ; then
- dosbin xmbmon
- fperms 4555 /usr/sbin/xmbmon
- fowners root:wheel /usr/sbin/xmbmon
- fi
-
- dodoc 00README*
-}
-
-pkg_postinst() {
- echo
- einfo "These programs access SMBus/ISA-IO ports without any kind"
- einfo "of checking. It is, therefore, very dangerous and may cause"
- einfo "a system-crash. Make sure you read 00README.txt,"
- einfo "section 4, 'How to use!'"
- echo
- ewarn "Binaries are setuid root!"
- echo
-}