summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/poolmon/poolmon-0.5.ebuild')
-rw-r--r--sys-cluster/poolmon/poolmon-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-cluster/poolmon/poolmon-0.5.ebuild b/sys-cluster/poolmon/poolmon-0.5.ebuild
new file mode 100644
index 000000000000..e6f03ba4bbab
--- /dev/null
+++ b/sys-cluster/poolmon/poolmon-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/poolmon/poolmon-0.5.ebuild,v 1.1 2014/09/18 17:25:35 mschiff Exp $
+
+EAPI=5
+
+DESCRIPTION="A director mailserver pool monitoring script for Dovecot"
+HOMEPAGE="https://github.com/brandond/poolmon"
+SRC_URI="https://github.com/brandond/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ net-mail/dovecot
+ "
+
+src_install() {
+ exeinto /usr/bin
+ doexe poolmon
+ dodoc README
+ newinitd "${FILESDIR}"/poolmon.init poolmon
+ newconfd "${FILESDIR}"/poolmon.conf poolmon
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/poolmon.logrotate poolmon
+}