summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-3.3.3-r4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.3.3-r4.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sys-devel/gcc/gcc-3.3.3-r4.ebuild b/sys-devel/gcc/gcc-3.3.3-r4.ebuild
index e227794aedfc..2cc2fd8e9ae1 100644
--- a/sys-devel/gcc/gcc-3.3.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r4.ebuild,v 1.8 2004/05/08 23:09:05 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3-r4.ebuild,v 1.9 2004/06/24 04:31:24 agriffis Exp $
IUSE="static nls bootstrap java build X multilib gcj f77 objc hardened uclibc debug"
@@ -317,7 +317,7 @@ src_unpack() {
# do not enable it, the pie patches won't apply
#use uclibc || mv -f ${WORKDIR}/patch/8?_* ${WORKDIR}/patch/exclude/
- if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ if use multilib && [ "${ARCH}" = "amd64" ]
then
mv -f ${WORKDIR}/patch/06* ${WORKDIR}/patch/exclude/
bzip2 -c ${FILESDIR}/gcc331_use_multilib.amd64.patch > \
@@ -450,16 +450,14 @@ src_compile() {
# X11 support is still very experimental but enabling it is
# quite innocuous... [No, gcc is *not* linked to X11...]
# <dragon@gentoo.org> (15 May 2003)
- if [ -n "`use java`" -a -n "`use gcj`" -a \
- -n "`use X`" -a -z "`use build`" -a \
- -f /usr/X11R6/include/X11/Xlib.h ]
+ if use java && use gcj && use X && ! use build && [ -f /usr/X11R6/include/X11/Xlib.h ]
then
myconf="${myconf} --x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib"
myconf="${myconf} --enable-interpreter --enable-java-awt=xlib --with-x"
fi
# Multilib not yet supported
- if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ if use multilib && [ "${ARCH}" = "amd64" ]
then
einfo "WARNING: Multilib support enabled. This is still experimental."
myconf="${myconf} --enable-multilib"
@@ -540,7 +538,7 @@ src_compile() {
einfo "Building GCC..."
# Only build it static if we are just building the C frontend, else
# a lot of things break because there are not libstdc++.so ....
- if [ -n "`use static`" -a "${gcc_lang}" = "c" ]
+ if use static && [ "${gcc_lang}" = "c" ]
then
# Fix for our libtool-portage.patch
S="${WORKDIR}/build" \
@@ -602,7 +600,7 @@ src_install() {
dodir /etc/env.d/gcc
echo "PATH=\"${BINPATH}\"" > ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
echo "ROOTPATH=\"${BINPATH}\"" >> ${D}/etc/env.d/gcc/${CCHOST}-${MY_PV_FULL}
- if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ if use multilib && [ "${ARCH}" = "amd64" ]
then
# amd64 is a bit unique because of multilib. Add some other paths
echo "LDPATH=\"${LIBPATH}:${LIBPATH}/32:${LIBPATH}/../lib64:${LIBPATH}/../lib32\"" >> \
@@ -764,7 +762,7 @@ src_install() {
exeinto /sbin
doexe ${FILESDIR}/fix_libtool_files.sh
- if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ if use multilib && [ "${ARCH}" = "amd64" ]
then
# If using multilib, GCC has a bug, where it doesn't know where to find
# -lgcc_s when linking while compiling with g++ . ${LIBPATH} is in
@@ -784,7 +782,7 @@ pkg_preinst() {
# Make again sure that the linker "should" be able to locate
# libstdc++.so ...
- if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ if use multilib && [ "${ARCH}" = "amd64" ]
then
# Can't always find libgcc_s.so.1, make it find it
export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"
@@ -796,7 +794,7 @@ pkg_preinst() {
pkg_postinst() {
- if [ -n "`use multilib`" -a "${ARCH}" = "amd64" ]
+ if use multilib && [ "${ARCH}" = "amd64" ]
then
# Can't always find libgcc_s.so.1, make it find it
export LD_LIBRARY_PATH="${LIBPATH}:${LIBPATH}/../lib64:${LIBPATH}/../lib32:${LD_LIBRARY_PATH}"