summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-7.1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/gdb/gdb-7.1.ebuild b/sys-devel/gdb/gdb-7.1.ebuild
index b805c4596762..b9539548b799 100644
--- a/sys-devel/gdb/gdb-7.1.ebuild
+++ b/sys-devel/gdb/gdb-7.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.1.ebuild,v 1.5 2015/02/20 15:42:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.1.ebuild,v 1.6 2015/02/27 08:14:05 vapier Exp $
inherit flag-o-matic eutils
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi
is_cross() { [[ ${CHOST} != ${CTARGET} ]] ; }