summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse/files')
-rw-r--r--sys-devel/sparse/files/sparse-0.3-makefile-fix.patch34
-rw-r--r--sys-devel/sparse/files/sparse-0.4-makefile-fix.patch11
2 files changed, 0 insertions, 45 deletions
diff --git a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch b/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
deleted file mode 100644
index a89316b54f11..000000000000
--- a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- sparse-0.3/Makefile
-+++ sparse-0.3/Makefile
-@@ -16,9 +16,9 @@
- CFLAGS += -DDEBUG
-
- DESTDIR=
--PREFIX=$(HOME)
--BINDIR=$(PREFIX)/bin
--LIBDIR=$(PREFIX)/lib
--INCLUDEDIR=$(PREFIX)/include
-+PREFIX=
-+BINDIR=$(PREFIX)/usr/bin
-+LIBDIR=$(PREFIX)/usr/lib
-+INCLUDEDIR=$(PREFIX)/usr/include
- PKGCONFIGDIR=$(LIBDIR)/pkgconfig
-
-@@ -38,7 +38,7 @@
- LIB_FILE= libsparse.a
- SLIB_FILE= libsparse.so
-
--LIBS=$(LIB_FILE)
-+LIBS=$(SLIB_FILE)
-
- all: $(PROGRAMS) sparse.pc
-
-@@ -101,7 +101,7 @@
- $(AR) rcs $@ $(LIB_OBJS)
-
- $(SLIB_FILE): $(LIB_OBJS)
-- $(CC) -shared -o $@ $(LIB_OBJS)
-+ $(CC) $(LDFLAGS) -Wl,-soname,$@ -shared -o $@ $(LIB_OBJS)
-
- evaluate.o: $(LIB_H)
- expression.o: $(LIB_H)
diff --git a/sys-devel/sparse/files/sparse-0.4-makefile-fix.patch b/sys-devel/sparse/files/sparse-0.4-makefile-fix.patch
deleted file mode 100644
index 5af1467b2c78..000000000000
--- a/sys-devel/sparse/files/sparse-0.4-makefile-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sparse-0.4/Makefile
-+++ sparse-0.4/Makefile
-@@ -81,7 +81,7 @@
- $(QUIET_INST_SH)install -v $$f $(DESTDIR)$(BINDIR)/$$f || exit 1; \
- done
- $(Q)for f in $(INST_MAN1); do \
-- $(QUIET_INST_SH)install -v $$f $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
-+ $(QUIET_INST_SH)install -v $$f -m 0644 $(DESTDIR)$(MAN1DIR)/$$f || exit 1; \
- done
- $(Q)for f in $(LIBS); do \
- $(QUIET_INST_SH)install -m 644 -v $$f $(DESTDIR)$(LIBDIR)/$$f || exit 1; \