summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild')
-rw-r--r--sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild
new file mode 100644
index 000000000000..c3dc548c9b06
--- /dev/null
+++ b/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/leechcraft-vrooby/leechcraft-vrooby-0.5.85.ebuild,v 1.1 2012/10/08 16:04:21 pinkbyte Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="Vrooby, removable device manager for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="~net-misc/leechcraft-core-${PV}
+ x11-libs/qt-dbus:4"
+RDEPEND="${DEPEND}
+ sys-fs/udisks:0"
+
+# TODO: Maybe simplify this or add apropriate function to leechcraft eclass?
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
+}