summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/mdadm/mdadm-2.4.1-r1.ebuild')
-rw-r--r--sys-fs/mdadm/mdadm-2.4.1-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-fs/mdadm/mdadm-2.4.1-r1.ebuild b/sys-fs/mdadm/mdadm-2.4.1-r1.ebuild
deleted file mode 100644
index 2f0d0ac4b962..000000000000
--- a/sys-fs/mdadm/mdadm-2.4.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.4.1-r1.ebuild,v 1.1 2006/04/25 05:41:51 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=sys-apps/portage-2.0.51"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.3.1-endian.patch #122269
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.4.1-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- doexe "${FILESDIR}"/raid-{start,stop}.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die
-}