summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/gdbm/gdbm-1.8.3.ebuild')
-rw-r--r--sys-libs/gdbm/gdbm-1.8.3.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/sys-libs/gdbm/gdbm-1.8.3.ebuild b/sys-libs/gdbm/gdbm-1.8.3.ebuild
index 90aeec8baff9..c650208088b4 100644
--- a/sys-libs/gdbm/gdbm-1.8.3.ebuild
+++ b/sys-libs/gdbm/gdbm-1.8.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3.ebuild,v 1.10 2004/07/02 08:45:11 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.3.ebuild,v 1.11 2004/07/24 06:57:17 vapier Exp $
-inherit gnuconfig eutils flag-o-matic
+inherit gnuconfig flag-o-matic
DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
@@ -17,16 +17,17 @@ DEPEND="virtual/libc
berkdb? ( =sys-libs/db-1* )"
RDEPEND="virtual/libc"
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
gnuconfig_update
+}
- ! is-flag "-fomit-frame-pointer" && append-flags "-fomit-frame-pointer"
-
- local myconf
- use static && myconf="${myconf} --enable-static"
-
- econf ${myconf} || die
- emake CFLAGS="${CFLAGS}" || die
+src_compile() {
+ append-flags -fomit-frame-pointer
+ econf || die
+ use berkdb || sed -i '/HAVE_LIBNDBM/s:.*::' autoconf.h
+ emake || die
}
src_install() {
@@ -37,13 +38,15 @@ src_install() {
INSTALL_ROOT=${D} \
install-compat || die
- dosed "s:/usr/local/lib':/usr/lib':g" /usr/lib/libgdbm.la
-
dodoc ChangeLog NEWS README
+
+ # temp backwards support #32510
+ if [ -e ${ROOT}/usr/lib/libgdbm.so.2 ] ; then
+ cp -a ${ROOT}/usr/lib/libgdbm.so.2 ${D}/usr/lib/
+ fi
}
pkg_postinst() {
ewarn "Please run revdep-rebuild --soname libgdbm.so"
- ewarn "Because things compiled against the previous version will not"
- ewarn "work"
+ ewarn "Packages compiled against the previous version will not work"
}