summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/files/eblits/src_install.eblit6
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index a55dc84f5072..ef1e96ab6a37 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.801 2011/12/04 16:27:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.802 2011/12/09 04:53:23 vapier Exp $
+
+ 09 Dec 2011; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/src_install.eblit:
+ Symlink /lib to the default ABI, not to a hardcoded default.
04 Dec 2011; Markos Chandras <hwoarang@gentoo.org> glibc-2.13-r4.ebuild:
Stable on amd64 wrt bug #382377
diff --git a/sys-libs/glibc/files/eblits/src_install.eblit b/sys-libs/glibc/files/eblits/src_install.eblit
index 4208d1039851..00680eaf2221 100644
--- a/sys-libs/glibc/files/eblits/src_install.eblit
+++ b/sys-libs/glibc/files/eblits/src_install.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.17 2011/11/16 16:07:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_install.eblit,v 1.18 2011/12/09 04:53:23 vapier Exp $
toolchain-glibc_src_install() {
local GBUILDDIR
@@ -80,11 +80,11 @@ toolchain-glibc_src_install() {
if [[ ${SYMLINK_LIB} == "yes" ]] && has_multilib_profile ; then
case $(tc-arch) in
amd64)
- [[ ! -e ${D}/lib ]] && dosym $(get_abi_LIBDIR amd64) /lib
+ [[ ! -e ${D}/lib ]] && dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /lib
dosym ../$(get_abi_LIBDIR x86)/ld-linux.so.2 /lib/ld-linux.so.2
;;
ppc64)
- [[ ! -e ${D}/lib ]] && dosym $(get_abi_LIBDIR ppc64) /lib
+ [[ ! -e ${D}/lib ]] && dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) /lib
dosym ../$(get_abi_LIBDIR ppc)/ld.so.1 /lib/ld.so.1
;;
esac