summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild')
-rw-r--r--www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild b/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild
index 30d9ce57b954..e50dc62639cd 100644
--- a/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild
+++ b/www-apache/mod_auth_token/mod_auth_token-1.0.6_beta.ebuild
@@ -29,3 +29,19 @@ S="${WORKDIR}/${PN}"
src_prepare() {
epatch "${FILESDIR}"/${P}-ap_pstrcat.patch
}
+
+src_compile() {
+ local flag=
+ APXS2_ARGS=
+
+ for flag in ${CFLAGS}; do
+ APXS2_ARGS+=" -Wc,${flag}"
+ done
+
+ for flag in ${LDFLAGS}; do
+ APXS2_ARGS+=" -Wl,${flag}"
+ done
+
+ APXS2_ARGS="${APXS2_ARGS} -c ${PN}.c"
+ apache-module_src_compile
+}