summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/b2evolution')
-rw-r--r--www-apps/b2evolution/ChangeLog10
-rw-r--r--www-apps/b2evolution/b2evolution-4.1.4.ebuild47
2 files changed, 54 insertions, 3 deletions
diff --git a/www-apps/b2evolution/ChangeLog b/www-apps/b2evolution/ChangeLog
index f92eee2892e9..7da68c667fd2 100644
--- a/www-apps/b2evolution/ChangeLog
+++ b/www-apps/b2evolution/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/b2evolution
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/b2evolution/ChangeLog,v 1.29 2008/02/22 15:43:08 hollow Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/b2evolution/ChangeLog,v 1.30 2012/07/27 21:52:09 mabi Exp $
+
+*b2evolution-4.1.4 (27 Jul 2012)
+
+ 27 Jul 2012; Matti Bickel <mabi@gentoo.org> +b2evolution-4.1.4.ebuild:
+ version bump (#417109, #282828); ebuild by jaervosz with update to EAPI4 by me
22 Feb 2008; Benedikt Böhm <hollow@gentoo.org> b2evolution-1.10.2.ebuild,
b2evolution-1.10.3.ebuild, b2evolution-2.4.0_rc2.ebuild:
@@ -135,4 +140,3 @@
05 Feb 2005; Daniel Drake <dsd@gentoo.org> +metadata.xml,
+files/postinstall-en.txt, +b2evolution-0.9.0.11.ebuild:
Initial commit. Includes security fix from http://secunia.com/advisories/13718/
-
diff --git a/www-apps/b2evolution/b2evolution-4.1.4.ebuild b/www-apps/b2evolution/b2evolution-4.1.4.ebuild
new file mode 100644
index 000000000000..962979e2491f
--- /dev/null
+++ b/www-apps/b2evolution/b2evolution-4.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/b2evolution/b2evolution-4.1.4.ebuild,v 1.1 2012/07/27 21:52:09 mabi Exp $
+
+EAPI=4
+
+inherit webapp eutils
+
+MY_EXT="stable-2012-04-03"
+MY_PV=${PV/_/-}
+
+DESCRIPTION="Multilingual multiuser multi-blog engine"
+HOMEPAGE="http://www.b2evolution.net"
+SRC_URI="mirror://sourceforge/evocms/${PN}-${MY_PV}-${MY_EXT}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[ctype,curl,mysql,tokenizer,xml]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r blogs/*
+
+ rm doc/*.*-*.html doc/*.src.html
+ dohtml doc/*.html
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/conf/_basic_config.template.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/{cache,media}/
+ webapp_configfile
+ "${MY_HTDOCSDIR}"/conf/_{basic_config.template,advanced,locales,formatting,admin,stats,application,config,icons,upgrade}.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}