summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/gnash/gnash-0.8.8.ebuild')
-rw-r--r--www-plugins/gnash/gnash-0.8.8.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-plugins/gnash/gnash-0.8.8.ebuild b/www-plugins/gnash/gnash-0.8.8.ebuild
index 94851f69743d..9242fb7718f8 100644
--- a/www-plugins/gnash/gnash-0.8.8.ebuild
+++ b/www-plugins/gnash/gnash-0.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.8.ebuild,v 1.11 2010/10/06 20:35:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.8.ebuild,v 1.12 2010/11/15 22:29:46 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -121,6 +121,11 @@ pkg_setup() {
die "Nsplugin requires the gtk gui."
fi
+ if use fbcon && use !agg; then
+ eerror "Building gnash with fbcon requires the agg renderer."
+ die "fbcon requires the agg USE flag."
+ fi
+
if use sdl; then
einfo "Enable SDL as gui frontend and sound handler"
fi
@@ -152,6 +157,9 @@ src_prepare() {
# Use external dejagnu for tests, bug #321017
epatch "${FILESDIR}"/${PN}-0.8.8-external-dejagnu.patch
+ # Fix building on ppc64, bug #342535
+ use ppc64 && append-flags -mminimal-toc
+
eautoreconf
}
src_configure() {